Announcement

Collapse
No announcement yet.

Xbox Elite V2 disconnets

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xbox Elite V2 disconnets

    I use an Xbox Elite V2 for a while no, wireless with the Xbox Wireless Adapter (the newer, smaller on) - I don't want to use the Controller wired and BT isn't working well either

    The empty profiles in the Xbox Accessories App are created as specified, removed from the assignment in Steam, and the corresponding profile created in reWASD.

    If I now play Fifa, the controller disconnecting every few minutes. I've tried everything possible, but nothing works.

    I use reWASD in German, so I don't know if that somehow collides with the English profile name in the Xbox Accessories App?

    BTW... Before installing reWASD all is fine... Just after I Installed it I have these Problems

  • #2
    Hey there!
    Please clarify, do these disconnects have some kind of pattern? Does the controller turn off while playing or when idle?

    Also, please check if you have this option enabled in the Preferences:

    Comment


    • #3
      The disconnects happen every minute to 5 minutes. This happens while I'm gaming, not when the controller is in idle.

      Comment


      • #4
        Hello!

        It may be a chance that the system itself shuts down your controller. Please try the steps below:

        1. In Device Manager, choose View by connection view
        2. Find your controller and navigate to the dongle (adapter)
        3. Check if it has Power Management tab in Properties
        4. Uncheck Allow the computer to turn off this device to save power
        5. Check the device tree to ensure that the option is off or absent for your dongle, controller, etc.
        6. If you are going to use Bluetooth, then perform the same steps for the Bluetooth adapter too

        The picture below is an example, you will need to find your adapter and controller:

        Click image for larger version

Name:	e7b45df5b9.png
Views:	113
Size:	422.8 KB
ID:	231709

        Comment


        • #5
          Already did that too. Disconnects are absolutely random. Sometime just after I started the Game, sometimes after an Hour, sometimes between minutes, but then really every Minute to 5.
          btw, I did all of what u guys suggested....

          Before I forget. I found a workaround to keep my Controller "alive"... If I mute the controller config with this "magic wand" there are no disconnects. At least I can use my Paddle Combos with the accessory's app.

          But that can't be a solution either.

          Comment


          • #6
            Thank you for the details. Unfortunately, I am still not sure what exactly happens. Could you please try a few more things for me?
            1. Go to Preferences () -> LED settings, switch to Xbox Elite 2 controller and uncheck all the options you see there. Then, try to re-apply your config (ensure that it doesn't include LED settings too) and check it again.
            2. Ensure that you do not use Rumble in your config. Also, please let me know if the game itself sends rumble to your controller. If yes, please try to switch the vibration off in the game's settings.
            3. Please send me the config that you are using. Right-click on the config's name to open the contextual menu and choose Open file location. I will need the correspondent *.rewasd file. No need to Mute anything, I need a file that causes the issue to re-check it on our devices.

            Comment


            • #7
              Thanks for helping. Did all u´ve been suggesting.
              Here's the config: https://easyupload.io/umeloy

              Comment


              • #8
                So, no matter if you have LEDs and Rumble or not, the controller still disconnects during the game, right?

                I have checked your config. It doesn't require the usage of the virtual controller, and I suspect that it may be a reason of the issue. Could you please try my updated config attached below? It should work similar to yours, with the paddles being remapped to the bumpers. Does the same happen with my edition?
                Attached Files

                Comment


                • #9
                  Hello, first of all thank you.
                  Unfortunately, I can't use the paddles. I imported the config, but the paddles are not responding.

                  I also have the problem that the 3 "empty profiles" created in the Xbox Accessories app are automatically replaced by completely empty ones when the app is opened.

                  In addition, the controller in reWASD has 4 profiles, the 1st (slot 1) when none of the 3 Controller Lights is on, the last one is slot 4, i.e. with the 3rd Controller Light. So there are 4 profiles.
                  A bit confusing...
                  Attached Files

                  Comment


                  • #10
                    Hello
                    I see that you have removed all mappings from the controller. In the Xbox Accessories app, only paddle mappings should be removed. If you remove them from all buttons, then the buttons may not work at all.

                    In your case, paddles may not work due to controller firmware. Check the firmware version of the controller and roll it back to 4.8 if necessary. More in this thread.

                    reWASD layers 1-4 overlap layers 0-1-2-3 on the Xbox Elite 2. When none of the slot bars on the controller are lit, this counts as the first slot in reWASD.

                    Comment


                    • #11
                      RAM Stealer No No No. Read ma last post carefully. It's remapping automatically. I appreciate ur help

                      Comment


                      • #12
                        I'll clarify, you need to manually unmap only the paddles in all Xbox Accessories profiles. The rest of the buttons should be left as is. Also, these should be different profiles, not the same one.



                        This message indicates that you have Slot 4 selected and no config has been applied to it. In this case, the slot does not replace anything on the controller, because there is no config in it.

                        Comment

                        Working...
                        X