Announcement

Collapse
No announcement yet.

Delay on Keyboard Macro

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Delay on Keyboard Macro

    I have added a double press remap to the F key (melee attack) on my keyboard, which is executed when I double press the F key as long as I hold the key down (Turbo is checked).

    Now I noticed that the F key has a delay (about 2-3 seconds)
    Doesn't sound like much at first, but enough in the game that you don't survive in PVP.

    Anyone have any idea how to get rid of the delay?

    Settings Screenshot added



    Click image for larger version

Name:	image_2808.png
Views:	284
Size:	40.4 KB
ID:	225433

    Last edited by bogus_247; 11.05.2021, 16:50.

  • #2
    There is a setting in reWASD preferences that can adjust the activator's activation time.

    Please visit reWASD preferences - Press Time.

    This is the setting you need

    Comment


    • #3
      This seems to me JUST the time BETWEEN the Press Time. I have a delay WITH pressing the Key after i've set a binding. The First Press is the Delay and for that there seems no solution for

      Comment


      • #4
        Hey there!

        The delay with the Single Press is normal when using a Double Press.

        In order to detect Double Press, reWASD detects the first press, then the first release and then it waits for a "Double Press time" set in Preferences. If during this time there was no new presses, then it is clearly a Single Press. If you press and hold the key, then the same time should pass, so we are sure that it is not a double press.

        However, it sounds pretty strange that you 2-3 seconds of the delay. Could you please try to set the correct time in Preferences? The delay should be lesser.

        Comment


        • #5
          Get out of the dust because I'm currently having problems again.
          It may like not be a second, but the delay on double Press is so high that it can lead to disadvantages.

          ​​​​​​​If I assigned a double press to a key, isn’t there a way to have the normal single press on the same key without the small delay?

          Comment


          • #6
            Hello!
            The delay is due to the time it takes to process which mapping will be used. You can reduce the delay by decreasing the Double press time in Preferences -> Press time.
            But in this case, you will need to press the button faster for Double press.

            Comment


            • #7
              Non-passthrough double press function will introduce delay no matter what remapping software you are using, it is what it is... (but it should around 80-90ms, HEHE )

              I set the double press time to 70ms when ver. 6.21 just came out and for some reason it causing stutter(or double output) again when i revisit it yesterday... You can't set low than 130ms before 6.21... anyway...

              Also , if i remember correctly , assign too much functions to a key may make the delay even worst.
              Actually , the only thing will be delay is the function assigned to the first tap, the melee should be trigger at once with no delay when you press for the sec. time... You don't even need to hold it down... Is the turbo causing trouble here ? I don't own it , so...

              I am not a fan of double press function, a fast response action like melee should not be map with double press function. I will map a mouse key just for the melee action only, and you don't need to press it twice...

              Comment

              Working...
              X