No announcement yet.

New Bug with Shifts never encountered before. Press/long press confusion.

  • Filter
  • Time
  • Show
Clear All
new posts

  • New Bug with Shifts never encountered before. Press/long press confusion.


    I noticed a very weird bug, I'm 100% sure it wasn't there before. So i either touched something in options or it appeared with the last update.

    When i use Start/menu button as a shift modifier and push a button once i'm supposed to be in the shift 2 config, i don't have the usual behavior from remapped buttons anymore.

    For example "D-pad right" press would be macro 1 and "D-pad right" long press would be macro 2. When I rapidly press Start and single press Right D-pad, i have the macro 2 instead of macro 1. Consistently. If i press Start, wait half a sec or more then single press right d-pad i have my macro 1 like usual.
    Shifts are behaving very weirdly in general. They just don't answer like they used to. Usually, Rewasd is capable of "shifting" to "shifts" extremely fast and register a button in that shift profile in a split second and come back to shift 0. Not only it doesn't work anymore but it activates other remappings that have nothing to do with what i pressed.

    I create a new profile with nothing but a shift 2 remapping, same issue.

    I also had another issue where pressing start + button would not activate the macro at all but THEN once i waited, pressed other buttons, and came back to press start (and ONLY start), it activated the macro i tried to do a few seconds before. Like it got the macro it was supposed to activate it and was waiting for start to be pressed again so it can launch the macro. It absolutely makes no sense from my point of view, i don't even know how rewasd could do that to begin with.

    Thank you for your help.

  • #2
    Hey there!

    The behavior sounds pretty strange, however, we doesn't seem to change anything in Shift mode and Activators this time. Could you please send me your config, so we could check it precisely from our side? You could easily get access to the config file from the context menu (activated by right-clicking on the config's name). Also, would be extremely grateful if you briefly describe the steps for me again: you are going to Shift, right? Then, you are trying to press the button with a combo on the Single press remapped in this Shift? And the issue happens if you do it pretty quickly, right?


    • #3

      As i said, there is still the same issue when there is no config at all. New profile, new config, 0 other mapping, still the same. Also, same issue with other controllers.

      To reproduce it simply (config test attached) :

      Create a new profile and/or config.
      Choose virtual xbox one.
      Unmap start/menu button that will be used for shift 1.
      Use a normal xbox controller on shift 0, use menu to access shift 1
      remap dpad right "single press" to a button, T keystroke for example, remap dpad right "long press" to another button, F keystroke. Apply config.

      Now open notepad and quickly shift to shift1 and dpad right. Use shift overlay shift for better visualization, as soon as you see shift 1 overlay, press right dpad once.

      The issue : You'll often have a F keystroke remapped on long press right dpad registered instead of T keystroke even if you barely press the dpad for less than 50 ms. (my long press time option is at 400ms).

      I'm also adding to that issue that the d pad is also being registered even when unmapped in shift1. But can't reproduce it in the previous test.

      And there are also other weird things that happened with shifts a few weeks ago maybe. Like the macros in my shifts seemed not to work as they used to, the time they took to execute seemed not right and inconsistent (even though they were well calculated) but i thought it was the game that was lagging and readjusted the pauses in macros accordingly. Still this didn't feel right and i'm pretty sure it came from rewasd even though i have no proof at all.
      Attached Files


      • #4
        Thank you for the details!

        I confirm that there is some issue, we will definitely check it with a team. It seems to be irrelated to the new update, but I definitely see it here. Sorry for the inconvenience. Will keep you updated.


        • #5
          Good, so it doesn't come from me then. I was starting to go a little paranoid on the macros because i think it's related to the other issues i've had that started like a few weeks or a month ago and that i mentioned at the end of my last message.

          For example, i had macros that i used to browse through a specific order of menus in game that were optimized to navigate the most efficient way between inputs and not waste time. But suddenly the macro didn't seem calibrated anymore, it worked, but it was going slowly or missed inputs and i didn't end up where i used to end up once the macro was done. And i had to modify most of my macros to be much more sluggish and permissive so they could do the same as they did before (meaning increasing pauses between inputs) but in a much longer time.

          That's very weird because a macro is a macro, it's always supposed to do the same thing no matter what. But i felt that it suddenly became inconsistent.

          Not sure how you could use that info or where to look for but i have to share it because if it's also a bug, i'd really like it fix so i can be sure i can always rely on the macros i created and spent time on.


          • #6
            I may need a config again, with the combos that do not work well. Maybe I will see something there.


            • #7
              The thing is i don't really have anything to give you. The configs i have don't really have an issue per say.
              I had my macros then it suddenly didn't work as it used to and had that behavior i described so i changed them.

              It's more of a consistency issue. Like the default pauses/delays between inputs in rewasd got modified without me knowing or something like this.


              • #8
                In that case, it will be difficult for us to understand how to reproduce the issue, because there are no initial steps by which it appears. And in general, we have not yet had any such requests for such strange combo behavior.

                Right now your configurations are working fine and that's great.
                If you notice a cause or steps that reproduce the same combo behavior, let us know.

                And thank you for paying attention to such things and helping us make the app even better than it is now.


                • #9
                  Hopefully, my other issues are linked to the first one i described and that you managed to reproduce, so it might be fixed at the same time.

                  I could try and investigate since i still have the bug from time to time and get my macros messed up out of nowhere but i wouldn't know where to search for and would be mostly too hard to do.


                  • #10
                    As soon as there is news regarding your first issue, we will definitely let you know.