No announcement yet.

Problem remapping Wechip Air Mouse

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem remapping Wechip Air Mouse


    I know this somewhat an exotic device to remap. It's a remote usually used for Android and Smart TVs, but can also be used on a PC.
    I can remap most of the buttons fine, but some of them just doesn't seem to work. For example, when I let reWASD auto detect the key for the menu button on the remote it shows the "X" key, but when I remap this key to something different it doesn't seem to overwrite it and it still inputs the "X" key.

    Any idea how to fix this or if this is even possible with the current support?

  • #2

    This device is not in the list of officially supported devices, so we cannot guarantee its correct operation with reWASD. However, some devices that have X-input mode can be recognized in reWASD as an Xbox One or Xbox 360 controller.

    Please clarify how exactly this device is detected in reWASD?


    • #3
      I can choose between mouse and keyboard with touchpad.


      • #4
        In any time you can select a different option, as our software allow the re-initialization. Still, as we never tested such device, it is only up to you.

        You can try both, initializing it as mouse and adding all the buttons as additional keys, as described here.
        Another option, in case mouse movement will not be working, is to initialize it as a keyboard and use only keys.

        In both cases, we do not guarantee this device working properly in our software, since it is a very specific device.


        • #5
          Yeah already tried both options, but some keys are still not working correctly. But thanks for your help anyway. 🙂


          • #6
            We are always glad to help!