Announcement

Collapse
No announcement yet.

Controller input not recognized right away

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Controller input not recognized right away

    Hello.

    I have a problem after updating to version 6. After connecting the Xbox One S controller via Bluetooth, it is recognized by reWASD, and remap is on. I can see the controller in the Windows app and input from it is recognized. But not one game or app can't recognize controller input until I turn off remap and enable it again. This wasn't a problem on version 5 of the reWASD.

  • #2
    Hello!

    Could you please describe which config you apply in this case? Does it include the virtual controller mappings?

    Would be great if you could share the screenshot of reWASD windows with the connected controller and applied conifg.

    Comment


    • #3
      Originally Posted by reWASDer View Post
      Hello!

      Does it include the virtual controller mappings?
      I don't really understand what it means. Under "Virtual controller settings" I have it mapped to "Virtual Xbox One".

      I attached screenshots with my config.
      Attached Files

      Comment


      • #4
        Hello!
        Yes it is. Try to remove the "Virtual Xbox One" through the magic wand, apply the config and see if the issue persists.

        Comment


        • #5
          Originally Posted by RAM Stealer View Post
          Hello!
          Yes it is. Try to remove the "Virtual Xbox One" through the magic wand, apply the config and see if the issue persists.
          You mean do the "Unmap all" option? Then I will lose all the input.

          Comment


          • #6
            Yes. The controller buttons will be muted and only the mappings you have assigned will work.

            Comment


            • #7
              Originally Posted by RAM Stealer View Post
              Yes. The controller buttons will be muted and only the mappings you have assigned will work.

              Why would I want that? Then I need to reconfigure hole controller from scratch. I'm sorry, but you seem don't understand the issue.

              When I connect the controller it's recognized by the program and config is applied to it. It's recognized by Windows standard "Game Controllers" program and I see controller input in it. But input is not recognized by any app or game, until I disable remap and enable it back again in reWASD. The configuration is fine, it works. It's just don't work right away and I need to go to the reWASD GUI to disable remap and enable it back again. It worked fine on v5 of software.

              Comment


              • #8
                Disable virtual controller here. You need to click on the Xbox One so that the automatic mappings disappear, then save the config.

                Click image for larger version

Name:	bmoe5VBc7zKPRA.jpg
Views:	19
Size:	238.2 KB
ID:	229608

                Comment


                • #9
                  Hello, interesting I had a similar issue with PS3 Navigator and Outer Wilds game.
                  When I started the game, auto-detect feature would start mapping I created (https://www.rewasd.com/community/con...00fb3acd4b17ae). Mouse is correctly configured but PS3 Nav doesn't react. I'd just Alt-Tab twice (to unmap/remap automatically with auto-detect feature) and then everything's fine.
                  I de-installed the game today (as I finished it), but I'll try to see if it has the same reaction on other games too.

                  Comment


                  • #10
                    Originally Posted by RAM Stealer View Post
                    Disable virtual controller here. You need to click on the Xbox One so that the automatic mappings disappear, then save the config.
                    If I do this "Apply" button becomes gray and I can't apply config. If I save this config, I can't enable remap, the error will pop up.
                    Attached Files

                    Comment


                    • #11
                      Originally Posted by antontkv View Post

                      If I do this "Apply" button becomes gray and I can't apply config. If I save this config, I can't enable remap, the error will pop up.
                      It seems to be a different config, because the one you have shown above included Shift mode with keyboard mappings, so in that case, the virtual controller is not required.

                      Could you please describe what exactly you want to achieve with reWASD?

                      Comment


                      • #12
                        Originally Posted by peio View Post
                        Hello, interesting I had a similar issue with PS3 Navigator and Outer Wilds game.
                        When I started the game, auto-detect feature would start mapping I created (https://www.rewasd.com/community/con...00fb3acd4b17ae). Mouse is correctly configured but PS3 Nav doesn't react. I'd just Alt-Tab twice (to unmap/remap automatically with auto-detect feature) and then everything's fine.
                        I de-installed the game today (as I finished it), but I'll try to see if it has the same reaction on other games too.
                        I am afraid we have the same issue here. If you use Autodetect with the config that includes the virtual controller, then this controller appears in the system when the game is already launched, and so it may not be detected at once. Usually, if you restart the game (including its launchers), it should be detected properly. We have some ideas about how to override this issue — we will need to create a "permanent" virtual controller, but this idea is not developed yet. It should be working correctly if you apply a config before you open the game.

                        Comment

                        Working...
                        X