Announcement

Collapse
No announcement yet.

Remap is turned off whenever cntl-alt-delete is pressed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Remap is turned off whenever cntl-alt-delete is pressed

    Very strange behavior I've found - whenever you press cntrl-alt-del, the remap functionality is disabled. This requires me to hold down the power button on a controller for 10 seconds then recommend, or launch remap and re-engage mapping whenever I've pressed this combo to kill a stuck process.

    Is this normal behavior?

  • #2
    Ctrl+alt+delete works as an emergency shutdown command for the remap. So yes, this is normal behavior.
    If you want to kill a hung process in Task Manager, you can open Task Manager directly with Ctrl+Shift+Esc command.

    Comment


    • #3
      That is...odd. Why would you hook into a key combo that has been used since Windows inception? It would be extremely annoying if other utilities did this, I can imagine if say, Rivatuner turned off it's hooking everytime ctrl+alt+del was pressed, people would be filling the forums. If you want to keep it default fine, but there really should be at least an option in settings to disable this.

      I'm aware of cntrl+shift+esc, but there are situations such as when full screen games lock up where only ctrl+alt+del can restore control.

      Comment


      • #4
        We will think about how to change this behavior or add the ability to adjust it in the settings.
        Thank you!

        Comment


        • #5
          I absolutely second this, Im an advanced user of my PC and absolutely hate CTRL ALT DEL turns off rewasd, it interferes with my other actions constantly.
          I'd like a toggle to turn this off and on.

          PLEASE.

          Comment


          • #6
            Originally Posted by ShadPTR View Post
            I absolutely second this, Im an advanced user of my PC and absolutely hate CTRL ALT DEL turns off rewasd, it interferes with my other actions constantly.
            I'd like a toggle to turn this off and on.

            PLEASE.
            Thanks for your vote. We will definitely take this into account!

            Comment


            • #7
              Originally Posted by Fragment Shader View Post
              Very strange behavior I've found - whenever you press cntrl-alt-del, the remap functionality is disabled. This requires me to hold down the power button on a controller for 10 seconds then recommend, or launch remap and re-engage mapping whenever I've pressed this combo to kill a stuck process.

              Is this normal behavior?
              Hey there🙋‍♂️!

              We have changed this behavior: added ability to turn off remapping by Ctrl + Alt + Del hotkey on Preferences​.

              Please check new reWASD 6.4 or read more about it and other new features by the link

              Comment


              • #8
                Originally Posted by iren.bratsun View Post

                Hey there🙋‍♂️!

                We have changed this behavior: added ability to turn off remapping by Ctrl + Alt + Del hotkey on Preferences​.

                Please check new reWASD 6.4 or read more about it and other new features by the link
                Great!! when games crash you need use this 3 butons

                Comment

                Working...
                X