No announcement yet.

Issues identifying Flydigi Apex 2

  • Filter
  • Time
  • Show
Clear All
new posts

  • Issues identifying Flydigi Apex 2

    Hi, I just purchased a Flydigi Apex 2 controller after watching and reading that all the additional buttons could be remapped. It arrived yesterday and I could not make it recognize the controller as an Apex 2, only as Xbox 360 (using X-input mode) without possibility to remap the additional buttons.

    followed the official guide on how to correctly pair it and videos of people connecting it to reWASD software (only the 2nd led from top to botton turned on, which would be connected through dongle and not using X-input), also tried connected through USB and it still doesn't find the controller. I read a few posts here, saw the supported controllers list, FAQ/getting started and some troubleshooting later led me to update the controller firmware (which I did), confirm that Joy.cpl shows the correct controller (it lists as Flydigi 2.4G Android) and within its properties - test I could see all the buttons being activated when I pressed them, so windows recognized the controller. I can also use the gyro as mouse using the controller, so feels like it's working, just not being recognized by reWASD.

    I read somewhere it needed to activate using the activator from their website but seems like it was supposed to update something on an android device, not the controller/PC. On the Flydigi Space software it recognizes the controller being connected (gives me the switch o

    software version - Free trial
    Controller - Flydigi Apex 2 latest firmware (6.0. something from May)

    Does anyone know if I missed something? Thanks!

  • #2

    Have you followed the steps like on this video?

    Is Apex 2 still recognized by reWASD as Xbox 360 even after you change the mode using a shortcut?


    • #3
      Originally Posted by Miron4ik42 View Post

      Have you followed the steps like on this video?

      Is Apex 2 still recognized by reWASD as Xbox 360 even after you change the mode using a shortcut?
      Hi Miron, thanks for the quick reply. I did follow this video, and it stops being recognized as a xbox 360 after switching mode. But it doesn't change the controller type as it shows in the video, it disappears completely after switching (shows the notification of it being disconnected as x-360), the icon grays out but nothing new appears.

      I also tried closing Steam, as I did connect the controller to it.


      • #4
        As I understand, once you change the mode to Android, reWASD doesn't recognize the controller at all. In your case, I would appreciate it if you could to collect logs of the gamepad connection. Here is how:
        1. Run reWASD as Administrator.
        2. Open 'Preferences > General', select 'Standard logging' with 'Service/Driver logs' only.
        3. Click the 'Start log' button and leave 'Preferences'.
        4. Connect your adapter and controller and wait a few seconds until it appears (or not) as a new device at the bottom left corner of the app.
        5. Go to 'Preferences > General' again and click the 'Stop log' button.
        6. In the message that will appear, click 'Open file location', find the archive that was created last, and send it to us.
        7. Unplug/disconnect all physical controllers and their adapters, if present.

        If you have accidentally closed the message, you can still find the archive in ​the C:\Users\Public\Documents\reWASD\Logs folder.​​


        • #5
          Hi, created logs for 3 different scenarios, using cable, dongle and dongle going from android mode to xbox mode (showining it picking up x360 mode)

          all following your steps (start log, connecting the hardware and turning on the controller, stop log)
          Attached Files


          • #6
            Hello again,

            Please download and install this tool on your PC. Then, check what firmware version is shown there.


            • #7
              As an option, try to plug Apex 2 into different USB ports. Check how it works via Dongle and Cable.

              Thanks in advance


              • #8
                Hi, the version is, shows as latest in the android app that I used to upgrade it.

                Looks like your second guess was right. the front panel and my USB hub did not work, but the back USB did the trick. Thanks for that, I think I can manage to connect the controller to the back.

                Will definitely buy the software, not sure if you work with the devs, but thanks a lot for your help =)


                • #9
                  Glad to know that the issue got resolved.

                  Should you have any other questions or require further assistance, please let us know.​