Announcement

Collapse
No announcement yet.

Was playing Warhammer 40K Darktide just fine, then.....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Was playing Warhammer 40K Darktide just fine, then.....

    The game had been ignoring my controller believing it was a keyboard as I use it in my left hand and a mouse in my right hand. Suddenly the game started recognizing my controller as a controller so I can no longer use my mouse (can't do both). In Steam I always make a custom config with all unassigned binds which wipes games with hard coded binds. Normally this confused games into thinking the controller with ReWASD is really a keyboard. I have 100 hours in this game and now I can't play. Any settings in ReWASD that would better hide the controller from this game?

  • #2
    Please send me the config you are using. Your configs are stored here: C:\Users\Public\Documents\reWASD\Profiles
    ​​​​​​​I need the correspondent *.rewasd file.

    Comment


    • #3
      Also please specify what controller you are using and how it is connected.

      Comment


      • #4
        Originally Posted by 1ncorrect View Post
        Please send me the config you are using. Your configs are stored here: C:\Users\Public\Documents\reWASD\Profiles
        I need the correspondent *.rewasd file.
        I am using a wireless Xbox one controller. Here is my log. Thanks.
        ​​​​​​​
        Attached Files

        Comment


        • #5
          There is nothing strange in the config. No virtual gamepad is created, and only keyboard mappings should work.

          Try disabling controller support in Steam and Xbox Extended feature support.
          If that doesn't help, try muting the native behavior of your gamepad keys.
          Click image for larger version

Name:	image.png
Views:	289
Size:	1.02 MB
ID:	236493​​

          Comment


          • #6
            I have tried all the Steam controller settings. Disabling it is what I normally do.
            Muting didn't help. Thanks​

            Comment


            • #7
              1. Could you send a screenshot of the full reWASD window with your config on it at the moment it is applied?
              2. Apply the config and open the gamepad tester. Is native controller input registered when you press buttons?​

              Comment


              • #8
                I tested with Click image for larger version

Name:	Screenshot ReWASD1.png
Views:	236
Size:	1.17 MB
ID:	236563 Gamepad tester and everything was recognized.
                I attached the screenshot you requested.

                Comment


                • #9
                  Native input of your controller is not muted, meaning that both controller and keyboard inputs would be sent simultaneously.

                  Please clarify, does your license include the [Advanced Mapping] feature? It is required for [Mute] function to block the controller inputs.

                  Comment


                  • #10
                    It still doesn't work for me for some reason(

                    Comment


                    • #11
                      Do you mean that Mute feature doesn't work? Please apply the config and check how it works, for instance, in Text document

                      Comment


                      • #12
                        Hi OP. I'm having the same issues as you are. Has this been resolved for you? I wanted to know before I create a new thread about this. Thanks!

                        Comment

                        Working...
                        X