No announcement yet.

Gyro get stuck/lag when mapped as mouse (Switch Pro Controller)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Gyro get stuck/lag when mapped as mouse (Switch Pro Controller)

    I have read existed posts about "gyro" "lag" but it's still not works. So I make a new post here.

    [ What is the problem ]
    I used to use Steam to map gyro as mouse. For some bugs of Steam controller mapper I started to use reWASD instead of Steam.
    I mapped gyro as mouse in reWASD. Feel stuck when moving crosshair / aiming. Seems like frame dropped but game FPS is actually nothing abnormal. Is there any workaround about this issue?

    Stucks actual behavior is based on Steam controller input and reWASD enabled state. See this table.
    Steam controller input reWASD mapping Behavior
    Gyro as mouse Disabled Works well
    Disabled Gyro as mouse Usually stuck in whole game
    Gyro as mouse Enabled but not mapped. Use native input Usually works well. Sometimes stuck

    [ Enviroment ]
    reWASD version: 6.5.1
    PC: AMD 5800x / RTX 3090 / 32GB RAM / 1TB SSD / 60Hz Monitor
    OS: Windows 10
    Controller: Nintendo Switch Pro / PowerA Fusion Pro for Nintendo Switch
    Game: Deep Rock Galactic (Steam)

    [ What I have tried (but didn't work) ]
    - Calibrate the gyro in reWASD
    - Use a new controller
    - Use wired controller (So it's not about the BT adapter)
    - Disable Steam controller input. Set virtual controller to XBox One ( Game only has native support with XBox )
    - Turn up the process priority of reWASDService.exe and reWASDEngine.exe in Task Manager

    [ Settings detail ]
    Gyro mapping: x=36 y=20 smooth=1 curve=default
    Game max framerate: 90

    [ Other guesses ]
    - It works well when I only use Steam. Stucks occur once I enabled reWASD. Is it possible that the polling rate of virtual device get lower for some reasons.​
    - My gyro has 3 degrees/s mistakes. Steam can catch these mistakes when I only use Steam. The crosshair should moves automatically until I calibrate in Steam. I found that virtual controller gyro is always 0 mistakes whether mapped or use native input. Is it possible that reWASD spent time to reduce the native gyro mistakes then cause stucks?

  • #2
    Hey there!

    You can try to turn off controller support in the Steam controller settings.
    Also, please ensure that there are no third-party software or remap programs on your PC.

    Please let us know if this helps resolve your issue.


    • #3

      I have tried to toggle on and off of Steam and reWASD. Sadly that Steam controller support off + reWASD on = Usually stuck in whole game. Same as the table I posted above in Home And there are no other remap programs.


      • #4
        Please send us the config you are using.

        Your configs are stored here: C:\Users\Public\Documents\reWASD\Profiles
        We need the correspondent *.rewasd file.

        Also, please record a video where we can see your issue.


        • #5
          Okay. I attempt to make a minimum config to reproduce this issue and record a video these days.