Announcement

Collapse
No announcement yet.

reWASD 6.3.1: More customization options, numerous small fixes, make sure to update!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • reWASD 6.3.1: More customization options, numerous small fixes, make sure to update!

    Greetings, everyone, and here comes reWASD 6.3.1!
    This release is fairly small, but we do hope that all the new things we have implemented will serve you well
    • Manage how the config content is displayed with the View menu
    Want to change what is shown in the config right now? Tap the View button, and choose the option you find handy:

    Click image for larger version

Name:	image.png
Views:	754
Size:	137.4 KB
ID:	233977
    • Change how Virtual controllers behave on device disconnection​
    Offline devices is one of reWASD 6.3 features, and we have customized it a bit further: now you can choose to "go back" to how it worked before. Check out Preferences - General, and set the desired behavior with the option Leave Virtual controller connected when the physical device disconnects:

    Click image for larger version

Name:	image.png
Views:	672
Size:	48.2 KB
ID:	233978

    Traditionally, this release packs some important fixes, such as:​
    • Fixed: If the list on configs is too long, the last one is not displayed properly
    • Fixed: Device panel scroll is displayed above the device icons
    • Fixed: Add the Z axis (yaw) and accelerometer inheritance from physical DS3 to Virtual DS3​
    We know that the massive UI update from 6.3 was quite a surprise for many of you, so I'd encourage you to check out an updated Workspace help article

    Many thanks to you all for the feedback, as you probably know, it shapes reWASD and makes it better with each and every release

  • #2
    Originally Posted by ✨Master Of Configs✨ View Post
    Fixed: Add the Z axis (yaw) and accelerometer inheritance from physical DS3 to Virtual DS3​
    Thank you for this! Finally, reWASD is using DS3's motion controls for something, not pretending that it is not existing. Always it is good to have the first step.😁 Is it possible that in the future we will be able to use these accelerometers for something else like other gyros (eg. mouse, right stick controls, tilting as the steering wheel or something similar)?

    I have noticed that DualShock4/SteamController/DualSense gyros are properly translated into Virtual DS3's motion controls. This is a great feature too! I like how reWASD is evolving. Soon every controller on PC will work out-of-the-box and have good support like on their console. I can't wait for the next update, to see what else we can receive. 😏

    Comment


    • #3
      Thank you so much for your feedback! Glad to know you're happy
      As for remapping DS3's motion controls to something, similar to how reWASD handles gyro on other devices, I think I'd need to have a chat with the team. So I'll be back with news later!

      Comment


      • #4
        Great update again! Thanks for the
        • Change how Virtual controllers behave on device disconnection​
        ​feature

        Comment


        • #5
          I'm super glad you enjoy the update!

          Comment


          • #6
            the new UI...causes a lot of troubles and needs me to redo the configs.
            Still haven't really gotten to the point where the profiles are running at startup.

            And I don't like the menu of the UI. I hate that fucking Windows bullshit with symbols instead of text.

            It's like going into the supermarket you finally learn where to find your shit and those idiots rearrange everything so you have to search from new.

            I think I will get to the point where it's working again well...but until then the update is just frustrating.
            please stop trying to invent the wheel again and again. Everytime you do you'll start with an uneven circle.​

            Comment


            • #7
              Originally Posted by steve42 View Post
              the new UI...causes a lot of troubles and needs me to redo the configs.
              Still haven't really gotten to the point where the profiles are running at startup.

              And I don't like the menu of the UI. I hate that fucking Windows bullshit with symbols instead of text.
              Could you clarify these points and send us screenshots?

              Thanks in advance.​

              Comment


              • #8
                I still have odd bugs with the new UI that came with 6.3 and I hope they get worked out because other than those there are some great features that came with it.

                -I use multiple sets of Joy-Con paired with PC at the same time (up to 4) that I connect / disconnect frequently, this always worked fine with previous reWASD versions but now sometimes I will connect a different pair and the on screen config won't display as if the controllers are connected. Like the on screen image of the controllers is still greyed out and also doesn't allow editing the buttons and gives a hover over warning that I don't have the right license for these features, when I do
                -The new behavior of not focusing the controller you connect has also led to issues, I would like an option to go back to the way it was before where I can turn on a controller and know that reWASD is looking at / editing configs for that controller immediately
                -There are some new odd bugs with 'show mappings' mode like sometimes it won't show a mapping unless I click into that mapping and go to that specific activator first, before it would just show any mapping on a button as it should

                Comment


                • #9
                  What version of reWASD are you using?

                  The controller focus problem has already been fixed in version 6.3.1.6778

                  Comment


                  • #10
                    Originally Posted by Miron4ik42 View Post
                    What version of reWASD are you using?

                    The controller focus problem has already been fixed in version 6.3.1.6778
                    I am on version 6.3.1.6778

                    Here is a quick video of what I mean: https://streamable.com/o8jgu8

                    I connect my controllers that are my 'Xbox' controller as they always have the Xbox controller config applied to them. The main screen shows the controller and the config, but the device selection stays on a disconnected controller. After selecting the controller I just connected, I turned that controller off and turned on another set of controllers. The selector stays on the Xbox config controller even though the main screen and layout is showing the config I have set for my newly connected controllers. Then I change a binding to and hit apply to show that it does not apply to the controller the main screen showing, it actually applies to the Xbox config controller because the device selector is still on that, so you hear the disconnection sound in Windows of my Xbox config being disconnected. And the controller I'm actually using doesn't have the config change applied to it as shown in notepad.

                    Comment


                    • #11
                      The solution may seem strange to you, but try the following:
                      1. Open → General and disable the Leave Virtual controller connected when the physical device disconnects option
                      2. Then open the Tray Agent tab and disable the Restore remap state on startup and device reconnect option
                      3. Save the changes with the Apply button.

                      After that, when a device is reconnected, the reWASD interface should focus on that device and its configuration.

                      Let me know if this works.​

                      Comment


                      • #12
                        Originally Posted by 1ncorrect View Post
                        The solution may seem strange to you, but try the following:
                        1. Open → General and disable the Leave Virtual controller connected when the physical device disconnects option
                        2. Then open the Tray Agent tab and disable the Restore remap state on startup and device reconnect option
                        3. Save the changes with the Apply button.

                        After that, when a device is reconnected, the reWASD interface should focus on that device and its configuration.

                        Let me know if this works.​
                        I tried it and it's the same, when I connect a new controller even though the middle of the screen will show the controller and config, it won't actually automatically select it in the device selector and stays on the last device.

                        I guess my main issue with the UI since 6.3 is that these two parts of it seem sort of 'out of sync' now, but before it was like one function that was easy to understand. Making it so devices don't disappear from the list when not connected was a nice change, but I don't think it was worth the new disconnect between the device list and the main screen UI that has come from that. Before they were always linked and it was easy to understand that you click a device what you see is for that device, but now it's like I have to make sure both of these different aspects are 'lined up' to know everything is good. I've been using rewasd a while so I can get it but I can't see this being easier for a newcomer to the software, it's going to lead to a lot of confusion.

                        Comment


                        • #13
                          I assume that the "Clear data" option may help.
                          [Clear Data] as [Preferences > General] should reset most settings.

                          Please let us know how the GUI behaves after you do Clear Data.

                          Comment


                          • #14
                            Originally Posted by Miron4ik42 View Post
                            I assume that the "Clear data" option may help.
                            [Clear Data] as [Preferences > General] should reset most settings.

                            Please let us know how the GUI behaves after you do Clear Data.

                            Clear data did not fix the issue, the device selector still is not synced up with the main screen on device connection/disconnection. I repeated the same sequence as in the video and the result was the same

                            Comment


                            • #15
                              We will try to reproduce this issue on our side.

                              For now, we suggest selecting the recently connected controller manually.

                              There is a chance that this issue can be fixed by giving unique names to the groups/controllers, so please try doing that too.

                              Comment

                              Working...
                              X