No announcement yet.

Unmap original key/button on Shift

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unmap original key/button on Shift

    Hi. I don't know if it is possible or I just can't find the option to disable the key that I assigned to a Shift shortcut. Example...L stick as a Shift key, but ignore the key event. Or, on a keyboard, WebSearch key as a Shift, but do not trigger the web search. It would allow me to set the Websearch key as a Shift, without messing with my Pc ( actually opening a web search).
    Thank You.

  • #2

    Yes, it is possible. You just need to Unmap Shift modifier not inside this shift but in the Main configuration (Shift 0).

    Click image for larger version

Name:	4b091dd3c1.jpg
Views:	402
Size:	36.7 KB
ID:	217282

    Go to Main layout, choose WebSearch, for example, and turn Unmap on for this button (1). Switch to Shift 1 (2), you will see that unmapped WebSearch was inherited. Then, choose this button as a shift modifier (3).


    • #3
      Thank you...sorry I figured out after I posted, but couldn't edit the post (not approved). Thank you.
      Now, please take a look at this recording...

      Is it normal behavior?. I have PgUp mapped as Shift+F2 on the first shift0 , then if i want to asign another key on shift 3 or shift 2, that happens...the 1st one mapped changes to none.


      • #4

        Thank you for your report. No, this is not normal behavior, will try to reproduce and figure out the reason of the problem.

        Our apologies for the inconvenience.

        UPD. We have been reproduced the issue. Apparently it relates when you have combos as mapping, no problem with a single mapping. Will try to solve this problem ASAP.
        Don't worry! Be Happy!


        • #5
          I can confirm on my part also that the issue is not present for a single mapping. Thank You for acknowledging.
          Another bug maybe? If i GROUP 2 accessories, as you saw in the video i posted, I don't have the battery icon. I mean, I have it the first time after I made the group, but after restarting rewasd, or just a while, the icon doesn't appear anymore, and it wont appear until I "disband" the group. Maybe it has something to do with the name, or idk.


          • #6
            As for another reported bug. We haven't reproduced it. According to your description, a device group was created using wireless Switch Pro (a group with Logitech g 300 mouse and Xbox 360 (keyboard grouped Using reWASD a while, restarting GUI or tray the battery icon stayed at the taskbar.

            Could it possible that icon was placed "Show hidden icon" menu of the taskbar (

            We would also appreciate more details regarding this problem in case it's still actual.
            Don't worry! Be Happy!


            • #7
              Here is a recordit with my issue..Now, after i un-group those you see that the icon suddenly appears. But after some time (idk how much time), it dissapears and never coming back until i ungroup them. Sorry about the recordit clip, maybe because i'm on 1440p resolution, the video is so big.

              UPDATE: It seems that it happens after my controller goes offline . The icon disappears, then after re-connecting it it never comes back. ( it is a wireless controller so it goes off after being idle for @ 15 mins.)
              Last edited by saberX; 17.09.2019, 07:40.


              • #8

                So, the icon disappears when a controller went offline and but was invisible even if the controller became online being in the group, right? Only group recreating helps to reappear the icon in the task manager.

                Do you have a similar problem with a single connected controller? Like the icon still unavailable if controller online after idle.

                Do you use some adapter to connect the gamepad unless it is a laptop with built BT chip?
                Don't worry! Be Happy!


                • #9
                  Ok, so I tried this without a group, and it seems that as soon as I connect a controller, the battery icon appears. It seems that my groups don't like being grouped lol. I even tried the controller first in group, or vice-versa, the keyboard first, the same result.
                  Btw it would be nice a notify, alert, something when the battery is low, so if I'm gaming I should be prepared to charge or swap batteries. Or maybe there is one, idk if my battery icon is acting poorly, maybe that's why I didn't noticed.


                  • #10

                    I think we've reproduced the problem (thank for your latest update). Confirm, that battery icon doesn't re-appear if the gamepad is in the group. Need to recreate a group to show icon again.

                    We fix this issue next update. Thank you for your cooperation and we take your suggestion regarding low battery status notification into account.
                    Don't worry! Be Happy!


                    • #11
                      Hi. Thanks. Until is fixed I will use an older app that i downloaded, that displays a battery icon, and also an alert for battery low. So no worries.