Announcement

Collapse
No announcement yet.

Xbox One Wireless Adapter with v5.2.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xbox One Wireless Adapter with v5.2.0

    I have the Elite Series 2 controller and I prefer to connect it to my PC using the wireless adapter rather than through Bluetooth. After updating to 5.2.0 to fully support the Elite Series 2, no mappings at all worked for me. I found that switching to Bluetooth worked fine, but I would still prefer to stick to my wireless adapter. Any suggestions, am I doing something wrong? Thank you.

  • #2
    Hello,

    Before using reWASD please ensure that you are on the physical Slot 0 on your Elite 2. Or you can go to Xbox app and create and an empty profile with no default or custom mappings on any button and apply this profile to all 3 physical slots. After, you will be able to add any kinds of mappings in reWASD.

    Check these items and try to reproduce the problem again.
    Don't worry! Be Happy!

    Comment


    • #3
      By physical Slot 0, I assume you mean having the Elite Series display no profile lights. I have it as the default (act like a standard controller which I believe is Slot 0) but it still does not do anything with the REWASD mappings I have. The Xbox Accessories app would not let me un-map all the buttons. It told me ABXY needed to be mapped when trying to continue. I did try with all the slots having no mappings on the paddles though. Thank you.

      Comment


      • #4
        Hello,

        Do not unmap other controls except paddles, just leave them by default.

        If you try to connect via wi-fi, please turn off the BT completely on your PC (laptop), re-apply the config.

        What the Elite v.2 firmware, by the way?
        Don't worry! Be Happy!

        Comment


        • #5
          I ended up leaving the controls default and just unmapping the paddles. I will try turning off Bluetooth and checking my firmware tomorrow morning. Just turned off my PC for the night. Thank you, and I’ll get back to you first thing tomorrow.

          Comment


          • #6
            Hello,

            Sure, feel free to contact.
            Don't worry! Be Happy!

            Comment


            • #7
              Hello Star-Lord,

              I turned off my Bluetooth and re-applied the config, but my controller still wasn't using my rewasd mappings. My Elite Series 2 Firmware is version 4.8.1908.0

              Thank you.

              Comment


              • #8
                Hey there! Could you please check the drivers that influence your controller?

                Here are the steps on the screen. I would be grateful if you do the same for me:

                Click image for larger version  Name:	0cd30c6290.jpg Views:	0 Size:	143.6 KB ID:	217603

                1. Go to Device Manager (type it in Windows search)
                2. Find your controller in the list (I have DS4, your controller may be detected in another way). Open its Properties (from the context menu)
                3. Go to Driver tab
                4. Click Driver Details
                5. Please send me a screenshot of the list of drivers


                There is another way to get there too, maybe it will be more convenient:

                Click image for larger version

Name:	9526d40d46.jpg
Views:	427
Size:	185.2 KB
ID:	217604

                1. Open your Explorer and paste this path: Control Panel\All Control Panel Items\Devices and Printers
                2. Find your controller and open its Properties (from the context menu)
                3. Go to Hardware tab
                4. Click Properties
                5. In the windows that will be opened, switch to Driver tab
                6. Click Driver Details
                7. Send me the screenshot of what do you see here

                Comment


                • #9
                  I believe it's this one. I'm using the Xbox One Elite Series 2 controller with the Xbox Wireless Adapter.
                  Attached Files

                  Comment


                  • #10
                    Thanks a lot!

                    Seems to be OK.
                    Could you please now go to C:\ProgramData\Disc-Soft\reWASD and remove all .bin2 files you see there?
                    Then please restart reWASD and try to Apply the config one more time and check how it works.

                    Comment


                    • #11
                      Click image for larger version

Name:	Controller Drivers.JPG
Views:	483
Size:	235.6 KB
ID:	217609Click image for larger version

Name:	Controller and Adapter.JPG
Views:	413
Size:	10.3 KB
ID:	217610

                      This is from the other way you posted. I tried to show both the Xbox One Wireless Controller Drivers and the Xbox Wireless Adapter for Windows Drivers.

                      Thank you.

                      Comment


                      • #12
                        Deleting the bin2 files worked! Thank you reWa SDer!! Now I can use my controller and the program seamlessly with my xbox adapter. Thank you for the all the help. This forum is really the best and I'm glad to be a part of the community!

                        Comment


                        • #13
                          Great news! Thank you very much for letting us know :satisfied:
                          Hope it will be the last issue you experienced with reWASD.

                          Comment

                          Working...
                          X