No announcement yet.

Using "Double press" on movement keys for dodge mechanic introduces input lag.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Using "Double press" on movement keys for dodge mechanic introduces input lag.

    Hey guys!,

    I am trying to setup double press with the WSAD keys to another binding (LShift) to execute the dodge skill (Doom Eternal).

    I've been looking on the forum and i have tried different settings / tutorials and I've managed to get it working. Let me elaborate.

    Lets take the D key as the example. With holding D normally you move to the right as a player. I wanted to be able to double tap the D key quickly to execute another key (LShift) once, but at the same time keep the D key active, so the movement doesn't stop. That works now with using "hold until release". But the double tap settings introduces a small input lag on the original D key.

    Changing the "Press time" settings and setting the Double press time to 0 removes the input lag, but makes the double press impossible to execute.

    Is there a way to use double press on the D key but without the input delay on the original D key? Thanks for your time!

  • #2

    So, you need press D and shift double-tapping. Please try to add also D mapping to Start press, like this - However, it gives double D input so the character will be twitching during the skill performing.

    Or you can try to create a combo and map to double-tap for example - In this case, after LShift triggering the D button is still being pressed 5 sec and releases. The duration you may tune as you need.
    Don't worry! Be Happy!


    • #3
      Thanks for the help!

      I tested both your recommendations. I had the most luck with your first recommendation, but as you mentioned it twitches the movement for a sec. I managed to get it working without the twitching.

      Instead of adding the D to the start press, i also tested with adding the D mapping to the Single press instead. That without Unmapping it. It still has a double input, but for some reason it doesn't interrupt the movement like this at all.

      If i double tap now, the dodge works nicely but if i keep the D pressed after the dodge, the dodge executes again because of the "hold until release" setting. So if i want to stop dodging i have to release the D for a fraction after the dodge.

      It actually works nicely like this because you can dodge twice in a row. If i keep the D key pressed after the double press, it dodges twice. If i release the key for a fraction after the dodge, it dodges once. Awesome!

      Playing like this is a blast!