Announcement

Collapse
No announcement yet.

When remap is on, game doesn't detect the controller

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • When remap is on, game doesn't detect the controller

    Hey team,

    I just acquired a Shadow subscription. I'm planning on using a Switch pro controller to play Fortnite.
    First, Rewasd. When I plug my controller and open rewasd, it detected the controller as an Xbox controller, which apparently makes sense (even though I saw a couple of screenshots showing that it could detect as a pro controller, but not here :/)
    Anyway. I remapped all the button to their original buttons, but reversed A and B.
    When I launch Fortnite, a weird thing happens. If the Remap is ON, the game doesn't detect a controller, nothing works. If I turn it off, it detects an Xbox controller and works, but I loose my remapping.
    What's weird is that it worked at some point, I have no idea what happened.
    One thing to note tho: except Fortnite, when remap is ON, the system seems to detect the remapping. For instance I tried a game controller test app, and not just detects the controller, but applies the remapping.

    What am I missing here? Thank you very much!

  • #2
    Hello!

    Seems you are using a virtual controller and reWASD, but Fortnite can't can't detect it at once.
    I would recommend you to re-launch the game (with Remap turned ON), and if it doesn't help, then reboot your PC (with Remap turned ON).

    A bit more info is here.

    I think it is normal that the controller is detected as Xbox. Shadow itself converts your controller to a virtual one using its drivers, and it only can create a virtual Xbox but not Nintendo.

    Comment


    • #3
      Hello!

      Thank for the quick response! I've already tried to reboot the game/computer, and had a look at the troubleshooting page, but no luck so far...

      Worst is, the behavior is now consistent:
      - Remap is ON, it doesn't work
      - Remap is OFF, I switch to the game window, controller is detected.

      :/

      Comment


      • #4
        Hello,

        Seems that the problem directly in the game as the system sees remapped controller inputs.

        1. Please check that the reWASD tray agent is running and active after the system restarts. Also, check that the "Enable autoremap on startup" option is ON (it checked by default, but to be sure).

        2. Try to restart (reboot) the system a couple of times with "remap is ON" as is the only way to force the game to detect the virtual controller.

        3. What config do you use?
        Don't worry! Be Happy!

        Comment


        • #5
          Hello,

          I've tried all those stuff, the problem is still here. Gonna try to share as much information as I can here.

          1 - PC Config

          Click image for larger version

Name:	Screen Shot 2020-03-25 at 11.48.51 AM.png
Views:	220
Size:	378.5 KB
ID:	218675

          2 - Controller Without remap

          Shadow sees a Nintendo Switch Pro controller

          Click image for larger version

Name:	Screen Shot 2020-03-25 at 11.44.37 AM.png
Views:	177
Size:	395.4 KB
ID:	218676

          joy.cpl

          Click image for larger version

Name:	Screen Shot 2020-03-25 at 11.44.49 AM.png
Views:	177
Size:	138.7 KB
ID:	218677

          Devices

          Note the "Virtual Input Device for reWASD". Not sure why it shows up. reWASD is launched at start, but not sure why it creates a virtual input.

          Click image for larger version

Name:	Screen Shot 2020-03-25 at 11.45.24 AM.png
Views:	176
Size:	370.0 KB
ID:	218678

          3 - Remap: ON

          Now, I open reWASD and put "Remap: ON". Here's my config. I just want to switch A and B for now, because they are reversed as Window thinks it's a Xbox controller.

          Click image for larger version

Name:	Screen Shot 2020-03-25 at 11.47.56 AM.png
Views:	178
Size:	614.0 KB
ID:	218679

          More information on the next post (5 attachments/post limit), but basically joy.cpl and device screenshot show that the remapping is working at the system level (in my understanding)

          Comment


          • #6
            new joy.cpl

            It seems to see the remap. When I go to "Properties" and try the controller, it's reactive.

            Click image for larger version

Name:	Screen Shot 2020-03-25 at 11.48.24 AM.png
Views:	186
Size:	125.0 KB
ID:	218681

            Devices

            As you can see, the new virtual controller is detected too.

            Click image for larger version

Name:	Screen Shot 2020-03-25 at 11.48.11 AM.png
Views:	176
Size:	415.6 KB
ID:	218682


            Hope this is useful!

            Thank you very very much for helping me out.

            Comment


            • #7
              Hello,
              Thank you for the detailed report.

              Well, according to the screenshot the reWASD does the job. It detects controller correctly, applies mappings and it works out of the game. Therefore:

              1. Check if this option is active
              2. Turn "remap is ON", in this case, Xbox 360 for the reWASD appears in the joy.cpl.
              3. Fortnite is pretty slow with detecting the new devices, so if you are using the virtual controller, I would suggest you to try to restart the game (with the Remap turned on). If it doesn't help, reboot your PC (with the Remap turned on) and try again.
              Don't worry! Be Happy!

              Comment


              • #8
                So it seems that everything went fine!

                Nothing related to what you just described though. After a Shadow update, my USB peripherals were finally forwarded properly to the Windows instance, therefore properly seeing a Pro Controller instead of a virtual xBox controller. Therefore ReWASD recognized the controller as is, remapped it, and Fortnite recognized too!

                Thank you again for your help

                Comment


                • #9
                  Hello,

                  Wow! Awesome, however, I'm was surprised that Nintendo is recognized as a native controller. Anyway, thank you for your feedback. Good to know that updates rule everywhere =).
                  Don't worry! Be Happy!

                  Comment

                  Working...
                  X