Announcement

Collapse
No announcement yet.

How to disable reWASD for games that don't need the controller support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to disable reWASD for games that don't need the controller support

    I just got this thing for Valorant, but that's the only game I'll need it for; everything else I play is already optimized to use a controller, so I want to disable the app when the other games are going. The interface on this thing is terrible and I have no idea how to see if it's even possible to do so and any help would be appreciated.

  • #2
    Hello!

    Please use Autodetect to apply a config automatically when the game starts.

    Here is an explicit guide how to adjust it.

    Comment


    • #3
      Thanks for the response but this doesn't help me. I want to use the regular game settings instead of having this on at all for certain games. It doesn't seem like I can set it up to do that.

      Comment


      • #4
        Hello,

        This is how autoredect works. The config with keyboard mappings applies ONLY when the Valorant process in focus, i.e when the game interface is opened. In other cases, you have a default controller.

        What doesn't work? The config is not applied automatically? What processes were added? Try to add all exe files from Riot Games\Riot Client and Riot Games\Riot Client\UX (4 exe files).
        Don't worry! Be Happy!

        Comment


        • #5
          I don't know why it's setup how it is. I only set the thing up for Valorant, but when I open up any other game, it still uses the same reWASD settings from when I had Valorant open.

          Comment


          • #6
            I'm trying to turn the entire thing OFF for every other game that's not Valorant, and it is not doing that. That is what my problem is.

            Comment


            • #7
              Please ensure that Remove applied config from slot on exit from the associated app option is checked in Preferences (the icon at the bottom right) -> Tray Agent tab.
              If it is on, your config associated with Valorant will be turned off once you switch to any other app.

              Also, you may need to check whether you have any other associated apps in reWASD set accidentally.

              Comment


              • #8
                Hey thanks, that's been checked since I downloaded the app but I still have the problem.

                Comment


                • #9
                  That is quite strange, so let's try to make a fresh restart for all the associations. Please follow these steps:

                  1. Close reWASD, exit the reWASD Tray agent too
                  2. Proceed to C:\ProgramData\Disc-Soft\reWASD and remove all the *.binv2 files from there. This folder is usually hidden by default, so you might need to press View tab in explorer and pick Show hidden items
                  3. Now reopen reWASD and set Autodetect for Valorant one more time.

                  Comment


                  • #10
                    I can't see the first thing, C:/ Program Data, it doesn't exist.

                    Comment


                    • #11
                      Hello,

                      It could be hidden, so check folder option at first and select "show hidden folder and drives" - https://prnt.sc/sx598x. Then check the directory again and proceed steps that reWASDer described above.
                      Don't worry! Be Happy!

                      Comment


                      • #12
                        Thanks, did all that and it's still doing the exact same thing.

                        Comment


                        • #13
                          Which *.exe files do you have in the list of associated apps?

                          Comment


                          • #14
                            Riot Client Services, RiotClientCrashHandler, and Valorant

                            Comment


                            • #15
                              Could you please take a screenshot of reWASD window after you minimized the game?
                              I mean switch to the game, make sure it works. Then go to reWASD again. It should be something like this:

                              Click image for larger version

Name:	09fb3a48de.jpg
Views:	584
Size:	126.9 KB
ID:	219851

                              Do you see the same?

                              Comment

                              Working...
                              X