Announcement

Collapse
No announcement yet.

Keyboard remapping not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Keyboard remapping not working

    Hello.

    I first heard about ReWASD two weeks ago when I was asking for some help with gaming accessibility options on Twitter. I am a disabled person so the number of buttons I can push on my keyboard is very limited. Thus, I really think ReWASD can help me because it should allow me to create shifts and then multiply the keys I can trigger with a small number of buttons.

    So I bought the software and started to try to remap some keys. I followed the official guide on keyboard remapping, but I click on APPLY and turn Remap ON, nothing happens: the keys are not remapped... I tried with or without the shift option but it changes nothing, it does not work. I managed to make it work somehow when I was doing tests, then I turned it OFF to actually remap the real controls I want, and it did not work... Now even tests with basic remap don't work.

    I have a laptop so I don't think that my keyboard is the problem... What can I do to make it work? ReWASD could really help me playing games I usually can't play... Thank you!

  • #2
    Hello,
    Thank you for your question.

    Please, specify how did you try to remap your keyboard? Do you want remapped keyboard use as the controller of part of the controller? May I ask you to provide some details to assist you properly.

    Thank you in advance.
    Don't worry! Be Happy!

    Comment


    • #3
      Hello,

      Thank you for your response. I'm left-handed so I mainly play with the Numpad keys. I would like to remap some keys of the keyboard to some others. For example, I would like to bind the -a key to -NumPad3. I would also like to create a shift on the -i button, so I can bind, for example, the -w key to -Numpad9 (in addition to the original -Numpad9 key). I hope I am clear... Here's a screenshot of the kind of remapping I want to do (it's not working).

      Click image for larger version

Name:	remap.PNG
Views:	51
Size:	391.6 KB
ID:	220637

      Of course if you have any questions, do not hesitate to ask. I have a Windows10 OS.

      Thank you again!

      Comment


      • #4
        Hello!

        Your config seems to be OK. Then it may be a chance that the device initialization is not completed correctly.

        Please follow these steps:

        1. Ungroup the Keyboard and Mouse, so all the devices are shown separately in the bottom left corner of the main window.
        2. Use Detection mode to find the correct Keyboard and Mouse. If you press the mouse button but see keyboard in reWASD, then you will need to re-initialize it (from the context menu of an active device): https://help.rewasd.com/interface/device-detection.html
        3. After you are sure about all the devices, please group Mouse and Keyboard and try to Apply your config and test it in a game or in Notepad

        Comment


        • #5
          Thank you really much! For some reason, ReWASD thinks that I'm using a mouse and not a keyboard, but now it works! I just had to click on "Mouse" and apply my config here!



          Thank you for your help, ReWASD will definitely change my life! Bye

          Comment


          • #6
            Hello,

            We glad that the problem has been resolved and wish you a great gaming experience.
            Don't worry! Be Happy!

            Comment

            Working...
            X