Announcement

Collapse
No announcement yet.

Controller buttons stopped working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Controller buttons stopped working

    I am using a PS4 dual shock via blue tooth. Basically I have two configs I switch between, one for PSO2 and one for Genshin Impact. GI is a normal controller with switched X and O buttons which works perfectly, and for quite some time both worked well switching between the two configs. The PSO2 remap is a bit more complicated in that it mixes controller buttons and some keyboard bindings. It was working perfectly for a few months now. Suddenly last week the controller buttons stopped functioning, but the keyboard binds are working like normal. I've tried making an entirely new config to fix this but it still wont register the controller buttons.. the controller is giving input as usual, I've checked it through the joy control panel file. One odd thing I've noticed is its making a virtual keyboard and controller in the bluetooth settings which may or may not have been present before this issue occured. The confusing part is that the button config is still working with genshin but not at all registering it in PSO2? BTW PSO2 is input toggled so its set to keyboard and I have tried switching it back and forth to controller then back to keyboard to no success. When I created a quick fix config all keyboard and mouse binds worked fine in game with the controller but it still wouldnt register any X, O, etc. At the time that it stopped functioning I dont recall anything I did out of the ordinary, though I did click detect mode for the first time which I dont see how it would break this partial amount..

    Any help at all would be appreciated, and I can provide additional information if necessary.

  • #2
    Hi there!

    PSO2 probably "binds" itself on the start to the first gamepad available, which is your dualshock, and ignores our virtual one. That explains why keyboard and mouse mappings still work.
    Check if you have an option [Hide physical controller when virtual one is created] in [Preferences > Gamepad] enabled in reWASD and apply the config before starting the game.

    Comment


    • #3
      While I didnt have it enabled currently (probably after clicking lots of stuff trying to fix it) I do think it was enabled when it broke, and I just tried to enable it before starting anything and still only the kb & m bindings applied.. this is driving me crazy! Maybe I should do a full reinstall..?

      Comment


      • #4
        Can you check if you have [Preferences > General > Hook controller buttons] enabled? There is a chance that disabling it might help in this case.
        You can also try to change the virtual controller and see if other two options would work.

        Don't forget that every time you apply the changes in the config or reWASD options you'll need to restart the game.

        Comment


        • #5
          It was enabled - I disabled it and tried it again to no avail.

          Eureka! Changing the virtual controller to Xbox One for whatever reason has returned it to normal. You sir are a wizard, thank you very much.

          Comment


          • #6
            Really thanks for this wonderful advice. I had the same problem but didn't know how to solve it. It's really simple. Although I recently started working in skyrora launch, but couldn't solve this problem myself

            Comment


            • #7
              Hello Fatichaddent79,

              So, what is your case? Specify some details or describe your problem.

              Thank you in advance.
              Don't worry! Be Happy!

              Comment


              • #8
                i have had success mapping, only for it to no longer work. similar to these cases. When i check hide physical controller, it goes to KBM. i can see everything running fine on gamepad tester, but not the app.

                Comment


                • #9
                  Hi rydo_25

                  What app or game? Are other controllers connected to the PC besides the one that is used for remapping? Please disable all spare controllers and left the only is being used.
                  What controller, btw? Launch the game after you turn remap ON, or restart the game with active mappings.
                  Don't worry! Be Happy!

                  Comment


                  • #10
                    Originally Posted by Star-Lord View Post
                    Hi rydo_25

                    What app or game? Are other controllers connected to the PC besides the one that is used for remapping? Please disable all spare controllers and left the only is being used.
                    What controller, btw? Launch the game after you turn remap ON, or restart the game with active mappings.
                    hey, sorry! i ended up figuring out that i needed to have the controller on prior to the game exe open for the game to see the controller correctly. game is warzone, controller is elite 2. After the update though, i am having another issue, however. i have a combo running on a trigger that was working prior to the update, but now instead of ending the (all keys up on R), the trigger continues to fire like it's being held in. any thoughts?

                    Comment


                    • #11
                      Originally Posted by rydo_25 View Post
                      i have a combo running on a trigger that was working prior to the update, but now instead of ending the (all keys up on R), the trigger continues to fire like it's being held in. any thoughts?
                      What combo is that? Can you either screenshot it or share your config file in some way?

                      Comment


                      • #12
                        Originally Posted by Shion View Post
                        What combo is that? Can you either screenshot it or share your config file in some way?
                        yeah, here is the screenshot of what worked prior to latest REWASD update. now it just continues the R trigger down action, even after release. i have tried deleting and making it again with the same results.
                        Attached Files

                        Comment


                        • #13
                          i've tried modifying the "100" next to the R trigger action but it only seems to work at 100. also, i don't see it working correctly on gamepad tester either. however, a double tap one works fine:


                          Click image for larger version

Name:	rewasd screenshot 2.png
Views:	1678
Size:	153.5 KB
ID:	222765

                          Comment


                          • #14
                            Was unable to reproduce with this combo. Can you send/share the config? You can find it here by default: C:\Users\Public\Documents\reWASD\Profiles\

                            On a side note I'd suggest using [Relative deflection], as any right-stick movement would reset that recoil-compensation:

                            Click image for larger version

Name:	image_2020-12-12_042055.png
Views:	1810
Size:	536.0 KB
ID:	222767

                            Comment


                            • #15
                              the one with the B works, but the other doesnt. were you able to get the 1st to work with no issues?
                              Attached Files

                              Comment

                              Working...
                              X