Announcement

Collapse
No announcement yet.

Controller buttons stopped working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Controller buttons stopped working

    I am using a PS4 dual shock via blue tooth. Basically I have two configs I switch between, one for PSO2 and one for Genshin Impact. GI is a normal controller with switched X and O buttons which works perfectly, and for quite some time both worked well switching between the two configs. The PSO2 remap is a bit more complicated in that it mixes controller buttons and some keyboard bindings. It was working perfectly for a few months now. Suddenly last week the controller buttons stopped functioning, but the keyboard binds are working like normal. I've tried making an entirely new config to fix this but it still wont register the controller buttons.. the controller is giving input as usual, I've checked it through the joy control panel file. One odd thing I've noticed is its making a virtual keyboard and controller in the bluetooth settings which may or may not have been present before this issue occured. The confusing part is that the button config is still working with genshin but not at all registering it in PSO2? BTW PSO2 is input toggled so its set to keyboard and I have tried switching it back and forth to controller then back to keyboard to no success. When I created a quick fix config all keyboard and mouse binds worked fine in game with the controller but it still wouldnt register any X, O, etc. At the time that it stopped functioning I dont recall anything I did out of the ordinary, though I did click detect mode for the first time which I dont see how it would break this partial amount..

    Any help at all would be appreciated, and I can provide additional information if necessary.

  • #2
    Hi there!

    PSO2 probably "binds" itself on the start to the first gamepad available, which is your dualshock, and ignores our virtual one. That explains why keyboard and mouse mappings still work.
    Check if you have an option [Hide physical controller when virtual one is created] in [Preferences > Gamepad] enabled in reWASD and apply the config before starting the game.

    Comment


    • #3
      While I didnt have it enabled currently (probably after clicking lots of stuff trying to fix it) I do think it was enabled when it broke, and I just tried to enable it before starting anything and still only the kb & m bindings applied.. this is driving me crazy! Maybe I should do a full reinstall..?

      Comment


      • #4
        Can you check if you have [Preferences > General > Hook controller buttons] enabled? There is a chance that disabling it might help in this case.
        You can also try to change the virtual controller and see if other two options would work.

        Don't forget that every time you apply the changes in the config or reWASD options you'll need to restart the game.

        Comment


        • #5
          It was enabled - I disabled it and tried it again to no avail.

          Eureka! Changing the virtual controller to Xbox One for whatever reason has returned it to normal. You sir are a wizard, thank you very much.

          Comment


          • #6
            Really thanks for this wonderful advice. I had the same problem but didn't know how to solve it. It's really simple. Although I recently started working in skyrora launch, but couldn't solve this problem myself

            Comment


            • #7
              Hello Fatichaddent79,

              So, what is your case? Specify some details or describe your problem.

              Thank you in advance.
              Don't worry! Be Happy!

              Comment


              • #8
                i have had success mapping, only for it to no longer work. similar to these cases. When i check hide physical controller, it goes to KBM. i can see everything running fine on gamepad tester, but not the app.

                Comment


                • #9
                  Hi rydo_25

                  What app or game? Are other controllers connected to the PC besides the one that is used for remapping? Please disable all spare controllers and left the only is being used.
                  What controller, btw? Launch the game after you turn remap ON, or restart the game with active mappings.
                  Don't worry! Be Happy!

                  Comment

                  Working...
                  X