No announcement yet.

Wrong config file format

  • Filter
  • Time
  • Show
Clear All
new posts

  • Wrong config file format

    Windows 10 Pro 19041.630
    reWASD 5.5.1
    XBox Elite 2

    I've used reWASD for nearly a year without any issues. About a month ago I got a second NVME drive, configured them in a RAID 0 array and reinstalled windows. After that I started getting the "Wrong config file format" error whenever I connect my controller or attempt to apply a config,
    Click image for larger version

Name:	Capture.PNG
Views:	1030
Size:	22.3 KB
ID:	222504
    I tried uninstalling and reinstalling reWASD, but that didn't change anything.

  • #2
    Is it always the same error? Can you get some logs by following these instructions?


    • #3
      Log files attached.
      Always the same error. Sometimes followed by another pop up that states that there are too many combos mapped, but I don't have any mapped at all.
      Attached Files


      • #4
        Here is the second error-
        Click image for larger version

Name:	Capture2.PNG
Views:	882
Size:	12.7 KB
ID:	222510
        It only occurs after turning on my controller.


        • #5
          Can you get the tracetext logs too?


          • #6
            Sure thing
            Attached Files


            • #7
              Hi there,

              This is an error that definitely comes from some issues with the JSON library. Unfortunately, at the moment, we can't reproduce this error from our side.

              I would ask you to share the config u are using (Ņonfigs are stored here: C:\Users\Public\Documents\reWASD\Profiles I need the correspondent *.rewasd file).

              But, I think, the better way is to format the drive and install fresh Windows 10.
              Don't worry! Be Happy!


              • #8
                Hello there!

                We got an update regarding the issue you were facing with. Please enter the following path:
                C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Newtons oft.Json\v4.0_12.0.0.0__30ad4fe6b2a6aeed

                And remove the Newtonsoft.Json.dll file contained in it. The similar case was just fixed, it may also work for you.

                Also, please make use the Explorer search to find all the Newtonsoft.Json.dll files contained in your system folder (C:\Windows and all the corresponding paths).
                Feel free to share a screenshot of files that are found there.

                Please keep us updated