No announcement yet.

Crash Xbox elite series 2 wireless

  • Filter
  • Time
  • Show
Clear All
new posts

  • Crash Xbox elite series 2 wireless


    I just installed rewasd few hours ago, and after configuration i realized everytime i switch between differents profiles with the profile button on the gamepad, all key bindings crash.

    What happens:
    - Only the Xbox button works after crash, all the others buttons does not work (when i press them, nothing happens - for profile button the gamepad led continue to work and indicate a profile switching)
    - Crash happens in bluetooth and with wire
    - If remap is off, there is no problem
    - Sometimes i can change 5 or 6 times of profiles, sometime 1 profile switching generate a mapping crash

    Is it a known issue ?


  • #2
    Hi there!

    Profile button on Xbox Elite switches slots when remap is on. So if you have nothing applied to other slots, you will be switching between yours and few empty configs, so it's not a crash actually.


    • #3
      I have set a config for each slot (default without any specific mapping if i dont need it) but nothing better.

      Also, i can have a crash when i switch from slot 2 to slot 3 which have both a configured mapping.


      • #4
        By crash you mean "app closes itself" or something else?

        Can you collect both types of logs by following these instructions?

        Would also like to get event logs from [Event Viewer]. Start it, open [Windows Logs], select [Application], right click on it and choose [Save All Events As...].


        • #5
          It's not really a crash.

          I mean, i suppose when i change of slot, there are 2 times: unmapping all buttons, then assign new mapping
          So, it seems unmapping successfully, but no new mapping.

          Application works well.


          After more testing, it seems i have 2 kinds of slots, on a side a slot with a assignment on "X" button ("B" button is assign on "X" button), and on the other side slots with assignments on paddles or no assignments.

          I tried to assign "X" to "X" on those slots, and now it works well. No more bug.

          For now i will not investigate, but if i do it, i will update this thread in a few days.



          • #6
            Hi there,

            Please, make sure that configs are applied to the corresponded slots in order - Perhaps, configs were initially applied to different slots.

            Xbox Elite 2 has 0,1,2,3 profiles, reWASD has reWASD has 1,2,3,4 responsively. So 0 config on the controller equal to 1 slot in reWASD. Make sure that the button on a controller has a 0 position to apply the config to slot 1.
            Don't worry! Be Happy!