Announcement

Collapse
No announcement yet.

gyro emulation lagging with wireless controllers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • gyro emulation lagging with wireless controllers

    hi reWASD,

    i'm playing on my laptop and am having a lot of input lag with the gyro emulation when going wireless with my joycons and ps4 controllers. on the other hand, when i go wired with the ps4 controller there are no noticeable issues at all. i've checked my bluetooth connections and noted only one controller is connected at a time. i've also worked to minimize any other wireless interference by switching my wifi from the default 2.4ghz to 5ghz so the two signals aren't conflicting.

    if this cannot be duplicated through testing, then the problem lies deeper somewhere on my spectrum and i'll investigate further; however, if this is a known problem is there a workaround for it?

    thank you!

  • #2
    Hi there,

    I would try to check the similar behavior with another BT adapter, in case it's possible. I am inclining, that this is a hardware issue, as everything works good via cable. What game (s) does the issue happen? What mapping are used?

    Does controller support is ON in Steam big picture mode (if you do use it)?

    Don't worry! Be Happy!

    Comment


    • #3
      hi Star-Lord,

      my laptop is fairly new, about 4 months old, and came with bluetooth built in, so i do not have a bluetooth adapter to try. the issue happens in paladins and realm royale. both games support gyro input from controllers and are the only gyro-enabled games i've tested the new ds4 gyro emulation on.vmy mappings are very basic. i simply use PS4 Remote Play and leave all binds default. the only change i make is mapping the gyro icon to the "Toggle Gyro On/Off" function. i do not use steam controller support as i've read in the past on this forum that it is not the ideal way to use reWASD.

      i should stress that the ONLY issue i am having is with gyro when going wireless. all analog buttons are working just fine with no delay.

      thanks for your attempt at troubleshooting! i'll keep trying other things out and will update this post if i find a solution.

      Comment


      • #4
        Hey there!

        If it is about gyro only, could you please try to calibrate gyro for both Joy-Cons?
        Also, one more question: have you grouped both devices?

        Comment


        • #5
          hello!

          I have calibrated all my controllers before and after experiencing this issue. I have also grouped both my joycons together as one controller (though I've noticed I've had to add the right controller first before the left to function properly).

          thank you!

          Comment


          • #6
            Thanks for the details!

            Yes, in a group, the gyro is working on one controller only, because once you plug both ones to the grip, both gyroscopes compensate each other.

            Still not sure why this issue happens. Could you describe a bit more so we could try to reproduce it from our side?
            In which game do you experience lags? What kind of lags do you feel — gyro responds slower, with a pause, you need to rotate your gamepad too fast to get any input?
            And you use both gamepads separately, without a grip, right?

            Comment


            • #7
              hi reWASDer,

              thank you for the explanation on the left/right joycon controller grouping order. that definitely makes sense.

              as mentioned, the issue is gyro-related only on both joycons and ps4 controller. i've tested the gyro function on the games Paladins and Realm Royale, both of which are cross-play enabled and support gyro input from controllers. i've tested on both my laptop & ps4 (via the External device option). you nailed the description of my issue with the "with a pause" comment. it stutters from one area i have pointed to the next. it is not a smooth left-right vice versa transition. i suspected that the new gyro function ("toggle gyro on/off") is doing exactly that - turning gyro on and off every time i move my controllers; however, i'm no longer certain this may be the case as the issue is resolved when i plug my ps4 controller in wired. sadly, joycons do not have the option to be wired so i cannot test that. if this is a possibility for my problem, would a "gyro always on" option resolve it?

              thank you again!

              Comment


              • #8
                sorry, forgot to add that, yes, i do use the joycons separately without the grip. i figured testing the ps4 controller would be the same as using the grip for my joycons.

                thanks again.

                Comment


                • #9
                  Gyro is always on when you do not use the command. So, it is on by default, so you can switch it off first, but if you do not use this mapping, it should be on always.

                  Thanks for the details, we will try to check these games with wireless connection to see what we have from our side. Will get back with any news!

                  Comment


                  • #10
                    Gyro is on by default. The lag is due to controller settings.

                    Comment


                    • #11
                      thanks guys!

                      mikaha21, what controller settings do I need to use to stop the lag over wireless connection?

                      Comment


                      • #12
                        hi guys,

                        just wondering if this has been tested to see if it is an issue or if it's just me. thanks again !!

                        Comment


                        • #13
                          Hello y0nkey !

                          Yep, we have tested one of the mentioned games, and we do detect the similar issue you have.

                          Nintendo controllers send reports much slower than DS4. We think that here is the cause of the problem. The game seems to be polling the gamepad faster than it actually can respond. We will need some time for the research, and unfortunately, at the moment we are not sure how to solve it. I will certainly keep you updated here!

                          Comment

                          Working...
                          X