Announcement

Collapse
No announcement yet.

Reprog Logitech G502 Additional Buttons

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reprog Logitech G502 Additional Buttons

    Hi - i just bought a new Logitech G502 Lightspeed mouse - im trying to reprogram the additional buttons around the mouse but REWASD is not recognizing them for me to regrom. Im using the Ps4 remote play function which ive used for my old mouse. but with this new mouse reWASD isnt recognizing the additional mouse buttons for me to reprogram

  • #2
    The idea is to remap those additional buttons to keyboard keys, save those mappings to mouse on-board memory and then remap those keys in reWASD via [Additional buttons] menu. This article explains it in a bit more detail.

    Comment


    • #3
      but with my other mouse all i had to do was go to the mouse additional buttons settings and remap to virtual playstation buttons. this new mouses additional buttons are not being recognized like my old mouses buttons were

      Comment


      • #4
        I don't have that mouse, so can't suggest anything else.

        Comment


        • #5
          Originally Posted by rishrosh View Post
          but with my other mouse all i had to do was go to the mouse additional buttons settings and remap to virtual playstation buttons. This new mouses additional buttons are not being recognized like my old mouses buttons were
          Probably before they were initialized as a mouse4 and mouse5 buttons. But this mouse initializes it as some unique ones. You can still use them if you can change them via the Logitech software. Also, Shion mentioned the needed article just for you. You should make your additional mouse buttons to work as some not-needed keyboard keys via the Logitech software, then in reWASD you can remap them using the 'Additional mouse buttons' tab.

          Comment


          • #6
            thanks im trying out both of your suggestions right now - will be back with the results. really appreciate your help

            Comment


            • #7
              Sure. Should you have any other questions or need any assistance - feel free to contact us back!

              Comment


              • #8
                so i tried this - and put numerical values in the logitech app. and then remapped these numericals values to remote ps4 virtual mappings and in game it still doesnt work

                Comment


                • #9
                  Click image for larger version

Name:	rewasd screen.jpg
Views:	58
Size:	82.3 KB
ID:	224506Click image for larger version

Name:	logitech.jpg
Views:	57
Size:	103.4 KB
ID:	224505

                  Comment


                  • #10
                    But on a screenshot I can see that you have not applied the config. Apply it and test it on a https://gamepad-tester.com

                    Comment


                    • #11
                      hey yep i applied it it and tested in game. just used your link i sent and same thing all other mouse buttons work EXCEPT the 3 I'm trying to map you website didn't recognize when i clicked these 3 buttons. But recognized everything else

                      Comment


                      • #12
                        The main thing we've forgotten to mention is that you must have the device with an on-board memory.
                        Or, otherwise, it may not work in reWASD.

                        So if you have any sort of toggle to the on-board memory mode in the Logitech software, it must be enabled.

                        Comment


                        • #13
                          thanks for all the help again.....but where would i find that? i have no idea where to look for that

                          Comment


                          • #14
                            i found it and got it to work thank you so much!!!!

                            Comment


                            • #15
                              Hello,

                              Was the question resolved in full?
                              Don't worry! Be Happy!

                              Comment

                              Working...
                              X