No announcement yet.

Games and Apps May Not Detect Virtual Controller Properly...

  • Filter
  • Time
  • Show
Clear All
new posts

  • Games and Apps May Not Detect Virtual Controller Properly...

    I am trying to use my xbox one controller emulated as keyboard and mouse for COD Warzone. Every time I hit apply I get this message:

    "Games and Apps May Not Detect Virtual Controller Properly if There are Physical Ones Connected. It is better to unplug them to avoid conflicts."

    I hit ok but it does not work. The controller does not do anything, it's like is asking me to unplug the controller to get it to work, but how will it work unplug. It makes no sense to me but maybe someone here already ran into this or I am just doing something wrong. Remap is on.

  • #2
    Most likely you haven't selected your Xbox One Controller as an active device at left bottom corner.


    • #3
      Hello, I have the same problem as above, I do not understand what Shion means to have a controller as an active device at left bottom corner, do you mean to have it as "Remap is ON"? in that case it is on, but still the controller doesn't work properly
      I find it works intermittently, and this is quite frustrating, what does the above message mean, and how can we resolve it?


      • #4
        Hey there!

        Shion hints at this corner:

        Click image for larger version  Name:	n2YZgNlhb8kkNA?d=1.png Views:	0 Size:	84.0 KB ID:	226435

        The device you are remapping should be selected here as an active one.

        This message appears if you are creating a virtual controller on some device and have other physical controller connected.

        It seems that some other device has a config that is applied, so that's why it may happen. We could try the fresh reset here. Please try this steps:

        1. Go to Preferences (a gear icon at the bottom right), General tab
        2. Click Clear data button and confirm your action
        3. Wait until the GUI and tray agent appear
        4. Initialize your devices from scratch and try again


        • #5

          Thanks for your answer reWASDer ,
          I have cleared the data from the settings. This seems to have got rid of the message "Games and Apps May Not Detect Virtual Controller Properly if There are Physical Ones Connected. It is better to unplug them to avoid conflicts."
          I don't know how to initialise the devices in your point 4, can you help?
          I don't have the golden [+] icon you are hinting at your screenshot above, how can I make it appear and what does it do?

          It still doesn't work well or quite at all. I have tested it both with creating a virtual X360 and XOne output controller and simila results.
          I have made a video, hopefully it helps:

          Can you please help?


          • #6
            The controller is selected, as needed.
            Please visit the reWASD preferences - Gamepads - Hide physical controllers when the virtual ones are created. Make sure this option is checked.

            If you use only a gamepad for the remapping, there is no need to initialize other devices, as a result, please skip the steps with devices initialization.

            You can check if the virtual controller is being detected and working properly by running the joy.cpl Windows tool (Win+R → joy.cpl → Run).

            There should be only one controller detected, and it should be only the virtual gamepad of reWASD.

            Another thing we can suggest is making all the mappings virtual (yellow colored). To do such thing, please assign the required mappings manually via the remapping settings.

            Let us know of any results. The main thing there, is a joy.cpl behavior. Only the reWASD's virtual gamepad must be appearing there. If it shows up, the mappings work correctly, the issue might be in the app you use, it might work not correctly with the virtual gamepads.

            Also, you are trying to apply the config on-fly. Please make sure to apply the config before the app opens. By making so, you will make sure the virtual gamepad is created before running the RetroArch app, so it is correctly initialized by the app before you start it.


            • #7
              Thanks for the answer wookiepediologist ,

              Settings -> "Hide physical controllers" has been always checked, even when I had the above error.

              joy.cpl returns behaviours that do not match with applications. This may lead to think that then the application I am using (Retroarch) is the problem, but I tried it with many other apps, and I get the same results, when Retroarch doesn't recognise it, the other apps won't either. So I cannot trust joy.cpl alone, something in the middle doesn't work, although joy.cpl can receive the segnal, maybe it is not brought to the drawn apps then.

              joy.cpl correctly shows only 1 device, it has always been like this, even when I had the above error.

              I made all the mappings virtual (yellow) in reWASD as suggested, the behaviour has not changed, and the pad intermittently works at times.

              Regarding applying configs on-the fly, for the sake of the video, I have held Retroarch opened, but I did tens/hundreds of same attempts with closing and reopening, so I can conclude that it is the same exact behaviour and that RetroArch is trustable in spotting immediately problems that serves the purpose to not annoy in the vide, that's why I show it, but I have the same behaviours with other applications.

              Here's a new video with all mappings, and switching virtual device type:


              • #8
                joy.cpl is a Windows tool which is mainly responsible for the gamepads' output in games.

                Thus, joy.cpl is the only thing which is mandatory in remapping.

                If everything works fine in joy.cpl, there is nothing else we can do to fix the issue you are facing with, unfortunately.

                If the issue is still happening, it is caused by the incompatibility issues between the joy.cpl, which is the main system tool for the gamepad input and the app you are using the gamepad in.

                I can only suggest running the Windows repairing tools/diagnosis tools, etc. The windows' reinstallation might work, even without the personnel files' removal.


                • #9
                  I would argue that it is inconclusive to say that because joy.cpl works, then the tool works fine - I tried other tools which work.
                  The only thing you can assume right now is that joy.cpl works and there's a misbehaviour somewhere.
                  Given that DS4Windows, AntiMicro, XPadder, work and reWASD intermittently works, then I cannot assume that it's not related to reWASD and you cannot as well.
                  Also reWASD works (approximately) 30-40% of times if I set a virtual output to be "Xbox One" and 10-20% if set to "Xbox 360". This proves that the Software changes variables inbetween.

                  I have no intention to reinstall Windows, the only tool that is not working as expected is reWASD right now.
                  What is the repair tools/diagnosis tools that you suggest, so that I can try?
                  Is there any other suggestion? For example, by removing drivers and how to do it?


                  • #10
                    Have you tried to restart the app after you applied a config? The games and tools often do not recognize the newly created device, and that may be an issue. Also, it is better to restart other launchers you may be using here.


                    • #11
                      Hello reWASDer , I confirm that I closed and reopened different tools, for example antimicro, retroarch, bsnes, etc, at times the joypad it is not recognised other times it is recognised, but the experience is the same with all the tools, and what I mean is, if it doesn't work properly in RetroArch, then it will malfunction in others too in my experience

                      Please find here a video where in the end I also close and reopen the apps, and with joy.cpl visible


                      • #12
                        As I can see, right after you restarted RetroArch, it detected the controller at once. If you have two or more physical gamepads reconnected during the play, you will probably get the same situation — your first gamepad is detected in the system, and when you create a virtual one while the tools/games are on, they may work or may not.

                        I am not sure if we can do anything here.


                        • #13
                          reWASDer just to be sure that I understood correctly,

                          right after you restarted RetroArch, it detected the controller at once.
                          Retroarch behaved the same before and after restart, if sees the controller in the right way (X360 Virtual controller). The problem is that no input flows to the Apps, both RetroArch and BSNES.
                          You can watch the video carefully and you will notice that once in the state "Remap is ON", RetroArch correctly sees the X360 Virtual controller and disconnects the real XOne Controller (I am using a XOne wireless controller in these tests). Viceversa when in the state "Remap is OFF", the real XOne is connected and the virtual X360 is gone.

                          your first gamepad is detected in the system, and when you create a virtual one while the tools/games are on, they may work or may not.
                          The behaviour I see and that you can see in the video is that regardless that it is physical or virtual, it is seen as just 1 controller connected, so each time the connected controller numbers equals 1.
                          But at times the virtual X360 Controller sends the right inputs, many other times not (approx. 10-20% from what you can see in the video, and that's the same stat I shared above).

                          Please let me know if the meaning was different and thanks in advance.

                          I believe that we are beating around the bush, and that the issue is somewhere that is not yet visible to our eyes, maybe someone has a new idea?


                          • #14
                            Hm, at first, I thought that the gamepad is not detected by the app, however, yep, I see now. So it is recognized but is not working? But it does work with a physical one? Pretty strange, moreover, I have just checked RetroArch, and I have no issues with it at all

                            Could you please re-check the settings the controller has in RetroArch, here are they. Maybe you have different mappings inside the app itself?

                            Click image for larger version  Name:	1295177cb7.png Views:	0 Size:	307.9 KB ID:	226455


                            • #15
                              reWASDer thanks for the help, I confirm my settings are right, in fact if you note on the video(s), intermittently reWASD mapping works, and when it works, it is recognised in RetroArch and all the inputs are rightly received, even all the complex ones.
                              I confirm I have big familiarity with RetroArch as well so I know how it works and how to set it up.
                              So it must be something else