Announcement

Collapse
No announcement yet.

Remap is off on XBox One gamepad by default

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Remap is off on XBox One gamepad by default

    Right now I have ReWASD running. I start my gamepad. ReWASD opens on my screen but it shows Remap is off. If I start a game, ReWASD will not work. Is there a setting I can change to make ReWASD always "Remap is on" when I start my gamepad?

  • #2
    Hello!
    Enable [Autostart the background agent] and [Restore remap state on startup and device reconnect] in the settings.

    Click image for larger version

Name:	V2VyQ8ZI8WqWXm.png
Views:	42
Size:	40.1 KB
ID:	226584

    Comment


    • #3
      Thanks for the response. I already had both of those settings checked. That doesn't work for me.

      Comment


      • #4
        Make sure [reWASDEngine.exe] or [reWASD: gamepad mapper engine (32 bit)] process is running and is not blocked at [Task Manager > Startup] tab.

        [Restore remap state on startup and device reconnect] will not restore anything if you previously disabled remap before closing reWASD, disconnecting your controller or restarting your PC.

        Comment


        • #5
          ReWASD is always running. It auto starts when I boot Windows. It's in my system tray.
          Typically after playing, my controller will turn off leaving ReWASD running. Many times I turn my controller back on and remap is foo again. I mostly leave my computer on but sometimes I reboot it.

          Comment


          • #6
            The point is that Remap must be ON all the time except when you disconnect the controller (then reWASD will turn it of on its own). Do not turn remap off for your controller manually at any time, and then with an option mentioned above reWASDEngine (not the reWASD app itself) will restore previously used config for the controller on its reconnect. At least reWASD should work this way for wired reconnection. I don't have information for Bluetooth connection at the moment.

            You can try the [Clear data] button at the [Preferences > General] to reset all the states for devices, apply the config for your controller and then try to reconnect it again.

            Comment


            • #7
              I never turn off ReWASD and still it doesn't always go to "Remap is on". It starts sometimes with "Remap is off". BTW, I have a wireless Xbox One controller.

              Comment


              • #8
                Originally Posted by Masterblaster View Post
                I never turn off ReWASD and still it doesn't always go to "Remap is on". It starts sometimes with "Remap is off". BTW, I have a wireless Xbox One controller.
                Have the "clear data" option helped you? If not, try reinstalling our application completely.
                Uninstall → Reboot PC, Install → Reboot PC again.

                Comment


                • #9
                  Hey there!

                  This situation may hint to some issues with the background agent that should enable the previously applied configs on the default settings. I would kindly ask you to check the Event Viewer logs to look for the possible crashes or warnings. Here are the steps:

                  1. Press Windows button, type 'Event Viewer', press Enter
                  2. Choose Windows Logs in the upper left corner, then choose Application
                  3. Check out the panel on the right side: there's a Find option. Click it, and type 'reWASD' to search for related errors Once you find one or multiple events, please right-click them, and choose 'Save selected events...', and send them to us.

                  Comment

                  Working...
                  X