Announcement

Collapse
No announcement yet.

reWASD doesn't see 2 extra buttons on my mouse

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • reWASD doesn't see 2 extra buttons on my mouse

    I ran into a problem, my mouse "Elecom Nendo Design Kasane Manta Mouse" has essentially 2 more buttons, namely the scroll wheel can be pressed left and right ,but reWASD does not see them, how to solve this problem? Thanks for developers
    Click image for larger version

Name:	61a2DjcjL1L._AC_SL1500_.jpg
Views:	143
Size:	70.4 KB
ID:	226697

  • #2
    Hello

    You need to assign keyboard buttons to these buttons in the native mouse software, and then remap them in the Keypad window. More about this in the manual.

    Comment


    • #3
      Originally Posted by RAM Stealer View Post
      Hello

      You need to assign keyboard buttons to these buttons in the native mouse software, and then remap them in the Keypad window. More about this in the manual.
      Thanks, but I do this, but it's not working, what am I doing wrong? Or maybe soft of my mouse is not perfect? Click image for larger version

Name:	2021-07-25_234924.jpg
Views:	82
Size:	109.8 KB
ID:	226725

      Comment


      • #4
        Originally Posted by Sbun View Post
        what am I doing wrong?
        Can't say from this screenshot alone. Does the [Tilt left] and [Tilt right] work as [Play/Pause] and [Mute] without reWASD?

        Can you try to enable [Detection mode] and do the tilts? What device icon is flashing when you do?

        If that device is your mouse, make sure it is initialized as mouse in reWASD (has a mouse icon, if not - right-click on its name and select [Re-Initialize]), and that you set mappings in [Additional mouse buttons] list of a [Mouse] sub-config, like this:

        Click image for larger version

Name:	2021-07-26_23-31-24.png
Views:	91
Size:	72.3 KB
ID:	226730

        If it's an another device, group it up with the mouse, initialize it as keyboard and set these mapping in [Keyboard] sub-config.

        Comment


        • #5
          Originally Posted by Shion View Post
          Can't say from this screenshot alone. Does the [Tilt left] and [Tilt right] work as [Play/Pause] and [Mute] without reWASD?

          Can you try to enable [Detection mode] and do the tilts? What device icon is flashing when you do?

          If that device is your mouse, make sure it is initialized as mouse in reWASD (has a mouse icon, if not - right-click on its name and select [Re-Initialize]), and that you set mappings in [Additional mouse buttons] list of a [Mouse] sub-config, like this:

          Click image for larger version

Name:	2021-07-26_23-31-24.png
Views:	91
Size:	72.3 KB
ID:	226730

          If it's an another device, group it up with the mouse, initialize it as keyboard and set these mapping in [Keyboard] sub-config.
          Yes without reWASD "play and mute" working fine.

          Mous detect fine with all buttons, instead "tilt left\right" .
          Click image for larger version

Name:	11111111111111111111111.jpg
Views:	77
Size:	204.2 KB
ID:	226734
          Attached Files

          Comment


          • #6
            It seems that reWASD is for some reason unable to catch [Play/Pause] and [Mute] inputs.

            Is it possible to set different keys/actions for the tilts? Ones that reWASD is able to catch?

            Comment

            Working...
            X