No announcement yet.

Star Citizen no axis response

  • Filter
  • Time
  • Show
Clear All
new posts

  • Star Citizen no axis response

    I am attempting to use a DualSense 4 controller with Star Citizen. I can get buttons to map to keyboard keys, etc.
    However the joystick axis are not working/responding. To be clear, the DualSense 4 joysticks have zero response in-game, but the other buttons do.

    The only thing that seems to work, is the native Xbox controller (when connected). Note: I do disconnect the Xbox controller as suggested by reWASD when I enable my DualSense 4 controller. Maybe it is worth noting, that when I do ignore this warning and have both game pads connected, they both work in-game (except the joysticks on the DualSense of course).

    I have deleted my Star Citizen USER directory (effectively restoring default configs in Star Citizen). I have also performed a "Clear Data" in reWASD (preferences, general, clear data). And lastly I have disabled my Steam "Controller" configs (possibly interfering?). Note: they never seemed to have in the past.

    Another note: My 'X4 Fondations' reWASD mappings work great (that game too does not recognize DualSense controllers and reWASD effectively virtualizes it as an Xbox controller just as it is suppose to do.)

    Any hints, help or ideas is greatly appreciated

  • #2
    To solve this problem we'd need to know the following:
    1. Do you have a DualShock 4 or DualSense controller?
    2. Does Start Citizen support DS4, Xbox 360 or Xbox One?
    3. Have you set reWASD to remap your controller to a virtual Xbox 360 or One?
      (click on the [Magic Wand] in the middle and select Virtual Xbox 360/One to do that)
    4. Do you have [Hide physical controller...] option enabled at [Preferences > Gamepads]?
      (it is recommended to have it enabled)


    • #3
      I was able to solve this by creating a completely new config. I wanted to edit my post to reflect this, but moderator settings have that disable for little ol me
      I say again; I got my issue solved, and really enjoying reWASD, worth every penny.

      When I use the default config provided by reWASD (virtual Xbox 360 controller), that does not work. If you would like me to troubleshoot that config I would be more than happy to do so!

      For completeness and to answer your questions:
      1. DualSense (sorry for the confusion, I always thought it was called DualSense four)
      2. Star Citizen supports the Xbox 360 controller.
      3. DualSense to Xbox 360 I believe. I'll try to post an attachment below.
      4. I do indeed.

      The following screen shot (if I uploaded it correctly), is the default Xbox 360 remapping of my DualSense controller. Unless I am mistaken? Regardless, it is this config that does not seem to work with Star Citizen. Double checked, before posting this response... still does not work. However! As I mentioned, I am able to make a new config and that works. So you may consider this topic closed if you wish.
      Click image for larger version

Name:	reWASD 9_10_2021 5_19_37 PM.png
Views:	1366
Size:	321.1 KB
ID:	227607


      • #4
        And the problem is right there on the screenshot. Based on the icon I see after 4th [Shift], that config remaps to a virtual Xbox One, which, I assume based on answer #2, is not supported by Star Citizen. New configs have virtual Xbox 360 set by default, so that's the reason new one works.


        • #5
          I am sorry, but how did you know that, and where does it say Xbox One? Am I understanding you correctly that the difference is with the outlined circle around the 'X' signifies 360 (my screen shot of my working config below)? Vs the first screen shoot where it does not have an outline around said 'X'? Did this happen during a reWASD update? The default config produced by the "Magic Wand' I clicked months ago, produced a 360 config (given the name in my first screen shot), but a new update to reWASD made that config an Xbox ONE virtual device without naming it maybe?

          Click image for larger version

Name:	reWASD 9_10_2021 6_29_07 PM.png
Views:	1041
Size:	554.2 KB
ID:	227610


          • #6
            Ah, I see now. Yes, I probably messed with that setting during my troubleshooting adventure.... toggling it now...

            HAHAHaaha yes, that worked. Setting it _back_ to 360 solves the issue. I wish I knew why I couldn't get it to work before (I recall it was set to 360). Obviously some other error on my part!


            • #7
              Am I understanding you correctly that the difference is with the outlined circle around the 'X' signifies 360 (my screen shot of my working config below)? Vs the first screen shoot where it does not have an outline around said 'X'?
              Yes. The icon shows what virtual controller is selected for current config. You can change it in two ways: by selecting another controller at [Magic Wand] menu or by clicking the icon itself to open virtual controller settings, the choice will be available there..