Announcement

Collapse
No announcement yet.

Xbox One Controller and Orc Must Die 3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xbox One Controller and Orc Must Die 3

    Hi all,

    I am tring to change the press and hold of the RTrigger to fire automatically, bgut it does nothing in the game

    For testing i tested mapping RT to the A button and it change nothing.

    What i am doing wrong ? This Steam game is not supported ? Thanks !

    Click image for larger version

Name:	GutgiH.png
Views:	100
Size:	406.2 KB
ID:	227722

  • #2
    Hi!
    We have checked on our side and the same mapping works on both the regular Single Press activator and the Long Press activator + toggle.

    Moreover, there is a section in the reWASD settings which is responsible for the pressing time for triggering certain activators (such as Double/Triple and Long Press).
    More information about this section of the Preferences can be found here.

    Please clarify, does this mapping doesn't work only in a certain game, or in other games too?

    Also check the work of this mapping on the gamepad tester. Does it work there?

    Comment


    • #3
      No tested yet on another game, but with gamepad tester :

      Toggle : do nothing

      Turbo :
      1 - stay blacked
      2 - blink as key press hold and release each 200 ms ( as in reWASD config )

      Click image for larger version

Name:	ItqJic.png
Views:	41
Size:	126.4 KB
ID:	227725

      Comment


      • #4
        As per your screenshot, everything works as intended. As per your message mentioned as turbo 1,2:
        1. This is how toggle works
        2. This is how turbo works
        Both functions belong to the Rapid Fire feature. Please check this article for the details.

        For your information, toggle makes the button continuously pressed, similar to how caps lock works. In order for the mapping to be constantly pressed, you should press the button at once and press the button one more time to release the mapping.

        In your case, as you want to apply toggle to "Long press" activator, you have to press the button for some time for the activator to trigger.
        Press time for triggering the mapping can be adjusted in reWASD Preferences → Press Time → Long press time as I mentioned in the previous post of mine.

        Comment


        • #5
          Ok for difference between toggle and turbo, it's more clear now

          But for turbo, the problem is same, if i hold press the RT, is't like the game does'nt recognize the reWASD command and work as original ( ie charge the power in place of fire each xxx ms)


          Thanks for helping by the way.

          Comment


          • #6
            Hello!
            Please send the config you are using. Your configs are stored here: C:\Users\Public\Documents\reWASD\Profiles.
            Also check if you have activated the Rapid Fire feature (button in the form of a key).

            Click image for larger version

Name:	MAjDglRU1LW0Pm.jpg
Views:	40
Size:	61.8 KB
ID:	227740

            Comment


            • #7
              Sorry for the delay, IRL is busy, will reply you this day promise.
              Thk again.

              Comment


              • #8
                Sure, we will be waiting.

                Comment


                • #9
                  Click image for larger version

Name:	SNAG-0168.png
Views:	17
Size:	64.1 KB
ID:	227808

                  Hi, the rapidfire license seem ok.

                  And here is my profile in attachment.

                  Just tested again, with 1ms turbo, and always do nothing.

                  Thanks for the support !
                  Attached Files

                  Comment


                  • #10
                    Thank you for the information provided.

                    The first thing I can recommend is to change the type of virtual controller.
                    First you change the type of virtual controller, then apply the config and run the game.
                    Click image for larger version

Name:	b27c58e241.jpg
Views:	22
Size:	295.1 KB
ID:	227811

                    If that doesn't help, maybe you should increase the turbo pause, because not all games can accept 1ms pause.

                    Comment

                    Working...
                    X