No announcement yet.

Xbox Series X controller via Bluetooth not detected

  • Filter
  • Time
  • Show
Clear All
new posts

  • Xbox Series X controller via Bluetooth not detected

    Hello there, I'm having similar issue with the person that posted this thread had.
    The only difference would be that I'm on Windows 11 instead of Windows 10.

    Some of the troubleshooting steps that I've tried are as follow:

    1. Post #6 regarding making sure mshidumdf in Registry has its Start key set to 3.
    Click image for larger version

Name:	gP0R.png
Views:	599
Size:	155.2 KB
ID:	228089
    In addition to that, I also found out that Owners key in my Registry initially had oem28.inf, which appeared to have something to do with a particular OEM recommended app, KB9X Radio Switch Device. So I went ahead and uninstalled said app, and removed the reference from Owners key (uninstalling said program and rebooting PC did not appear to automatically remove it).
    I've attached containing the file if you'd like to inspect it further, just in case.

    2. Post #4 regarding using in-app logger. File is

    3. Partially post #8 regarding checking the controller's firmware version. Should be up to date.
    Click image for larger version

Name:	x9Fy.png
Views:	662
Size:	80.4 KB
ID:	228088
    Attached Files

  • #2

    Thank you for the detailed information. We are working on this issue so reWASD won't depend on other drivers. Will keep you updated.

    Seems that in your case, this is an internal device, and so it is better not to try removing it. Hope we will have good news soon.


    • #3
      Hi there!

      Were you referring to the Bluetooth device itself being an internal device? If I understood correctly, then yeah, it's a built-in one (I'm on a laptop).

      If it helps further, I've also attached rewasdboot.etl following the steps from post #8.
      Attached Files


      • #4
        I am about Radio Switch Device you have mentioned. Seems it requires this driver too. Do you know what is it?
        Thank you for the logs!


        • #5
          Originally Posted by reWASDer View Post
          I am about Radio Switch Device you have mentioned. Seems it requires this driver too. Do you know what is it?
          Thank you for the logs!
          From what I could gather, it was an accompaniment device/driver that allows Win 8 and above to turn on/off airplane mode with Fn+F10. It seemingly would turn on/off the WiFi card entirely (unsure if hardware switch), which would also turn on/off Bluetooth, as I believe both are on the same card.
          However having it installed is not a requirement, though I will lose the ability to use the Fn+F10 shortcut.


          • #6
            In this case, if you do not use it too often, you could try to Uninstall the device from Device Manager after you remove the driver software. Do not try to remove the driver manually though, so we are sure that nothing is corrupted.


            • #7

              It seems what I uninstalled initially was only the accompaniment app (my claim in the original post), and was not the actual device/driver.
              Disabling the device then rebooting PC finally makes reWASD detect my controller via Bluetooth properly.
              I previously tried uninstalling the device, but that did not seem to be effective, as Windows would somehow reinstall its driver automatically.

              Though I do hope you guys will still make reWASD work even with having third-party devices like that installed in the future! Anyways, thanks for your time!