No announcement yet.

PS Now and DualSense

  • Filter
  • Time
  • Show
Clear All
new posts

  • PS Now and DualSense

    Hello, I'm using a DualSense Controllwer with Rewasd on PS Now and seem to be having an issue. Every time I emulate an Xbox controller PS Now will pick it up, but when I try to emulate the Dualshock it disconnects on PS Now. I've even tried using the mouse and keyboard emulating a Dualshock but no luck. I've restarted PS Now with the Dualshock emulation already set and still nothing.

  • #2
    Can you please clarify if the system sees the virtual DualShock 4 created by reWASD at all?
    Apply config with virtual DS4 emulation, and type joy.cpl into Windows Start menu. A window with a list of connected controllers will appear.
    Send a screenshot of this window.

    You can also test your virtual DS4 with a gamepad tester. Do you get a response from the buttons in the tester?

    We are waiting for your answer.


    • #3
      Hi thanks for the quick response
      Here's a screenshot of the joy.cpl screen
      Click image for larger version

Name:	Screenshot (104).png
Views:	583
Size:	688.1 KB
ID:	228151


      • #4
        And I did get a response from the buttons on the gamepad tester yup


        • #5
          Please follow these tips:
          1. Apply your config BEFORE you start PS Now. Close PS Now, enable remap, start PS Now again.

          2. Ensure that you see this icon in PS Now

          :Click image for larger version

Name:	e0f7640d32.jpg
Views:	541
Size:	13.5 KB
ID:	228155
          It means that you are in a controller mode, and gamepad is a primary device.

          If these conditions are met, but the virtual DualShock 4 still doesn't work, it's likely that this is a PS Now issue, or the game is incompatible with the DualShock 4.

          Furthermore, you say that the gamepad tester shows normal functionality of our virtual DS4, and it is correctly detected by the system.


          • #6
            I'm seeing now that the virtual DS4 is not connecting to my computer, but I'm not sure why. The wireless controller coming up under joy.cpl is the physical controller. When I change to DS4 and have my physical controller hidden under rewasd preferences, nothing shows up under joy.cpl. When I emulate the xbox controllers, those do show up under joy.cpl.


            • #7
              Please send me the file with system information. It doesn’t include any personal data but shows active processes, installed apps and drivers. It will help us recreate the same conditions and reproduce the issue from our side.
              1. Type ‘msinfo’ in Windows search
              2. Press Enter to open System Information tool
              3. Go to File → Save
              4. Send me the *.nfo file you get


              • #8
                Thanks I just private messaged em to you