No announcement yet.

ps3 controller seen by rewasd but not by psnow

  • Filter
  • Time
  • Show
Clear All
new posts

  • ps3 controller seen by rewasd but not by psnow

    Hello, I tried rewasd yesterday to use a ps3 controller as a ps4 controller on psnow, it worked like a charm. Then I decided to uninstall ScpToolkit as I tought it was redundant (I used it to use ps3 controller as x360 controller for old games), but now I'm unable to use the controller at all. Rewasd detect the controller (it detect when i click a control on the controller in the remap, and if i click on the ds3 icon it vibrates, and the overlay show the correct ramapped controls when clicked), but it's not detected at all by ps now, the controller icon is always grey.
    I tried to uninstall and reinstall both rewasd and psnow several times (and even ScpToolkit), other than the controller drivers, but I'm not able to make it work.
    Any idea? 😅

  • #2
    Check whether it works well via joy.cpl. Open Windows search (by pressing Win keyboard button, for example), enter joy.cpl and press Enter. Here you have all the controllers that are currently connected to your PC. One of them is a virtual controller emulated by reWASD, the way it shows up in the system differs from the chosen controller type. DualShock 4 shows up as Wireless Controller.
    Choose the needed controller, press Properties and try to press the buttons on your physical and remapped device, and check if they reproduce.

    Also, make sure that you hide the physical gamepad (Preferences — Gamepads).

    If this does not help, also send a screenshot of your config.


    • #3
      inside joy.cpl no controller is detected (see attachment) while remap mode is on. I even tried with a third party x360 controller and while is not on remap mode windows and ps now detect it (and it appears inside joy.cpl), when I active remap mode (with th same configuration as the screenshot) neither windows nor ps now detect it.
      Physical gamepad inside preference is checked.

      Click image for larger version

Name:	b.jpg
Views:	374
Size:	115.3 KB
ID:	228234Click image for larger version

Name:	a.jpg
Views:	530
Size:	24.9 KB
ID:	228235


      • #4
        I think your system has third-party mapper components/drivers that hide the virtual DS4 emulated by our software. Namely: vigembus driver, hidguardian, SCPtool. You need to remove these mappers for reWASD to work correctly. We do not recommend installing other remappers together with reWASD at the same time, because they may conflict.

        Also, if you have DS4Windows, make sure the 'Hide DS4 controller' option (in the main settings) is disabled.


        • #5
          I uninstalled every mapper application and every third party driver, then uninstalled and reinstalled rewasd, but still I'm unable to make it work 😅
          When remap is off joy.cpl shows a ps3 controller, when it's on no controller shows there, but under devices (settings) virtual dualshock for rewasd appear.

          Click image for larger version

Name:	c.jpg
Views:	513
Size:	212.4 KB
ID:	228245Click image for larger version

Name:	d.jpg
Views:	505
Size:	216.6 KB
ID:	228246


          • #6
            Please send me the file with system information. It doesn’t include any personal data but shows active processes, installed apps and drivers. We will check if there is something that may prevent DS4 from appearing in the system.

            1. Type ‘msinfo’ in Windows search
            2. Press Enter to open System Information tool
            3. Go to File -> Save
            4. Send me the *.nfo file you get


            • #7
              In the end it was a vigembus driver that was still installed, despite it wasn't displayed inside Device Manager. I had to use Driver Store Explorer to uninstall the driver, then reboot windows, and finally uninstall and install rewasd again. Now everything works as it should.
              Thanks @RAM Stealer, I forgot about vigembus.

              Have a nice day


              • #8
                Great news!
                We are glad that the issue has been solved.