No announcement yet.

Moonlight / Shield pro controller doesn't recognize unmap binds anymore

  • Filter
  • Time
  • Show
Clear All
new posts

  • Moonlight / Shield pro controller doesn't recognize unmap binds anymore

    Hi !

    First i wanna say that your app is awesome.
    I did a lot of research to find something like your app for controller.

    Soooo, i have to explain my attempt first and what is wrong next.

    To begin :

    I'm a user of a DS4 controller since i bought a PS4 a lot of years ago !
    And as you probably know, there is a button share that enable screenshot with simply press on it on your PS4/PS5.
    At beginning, i wasn't used to this thing but with the time i felt in love with this feature.

    And now i wanna this same feature on my PC !
    So first i had to find the awesome software which is DS4Windows to do this.
    Second the software for screenshot, after a lot of testing on different software i choosed Nvidia overlay.

    It work perfectly with my physical controller connected to my PC and same if i use my controller connected to 8bitDo adapter with Xinput/Mac or switch mode :

    Click image for larger version

Name:	2021-11-28_09-02-45.png
Views:	986
Size:	162.4 KB
ID:	228668

    But what could be wrong in this wonderful world ?​
    And this is where the hard part begin !

    I recently bought a Shield pro for my TV in order to let my PC in my office and play it without moving it (this is the purpose of nvidia shield i guess :p).
    I had a lot of problems to make it work as i wanted to do (i'll pass on details, it's not really interesting for understanding my problem) but finally i'm used to this thing.

    What i understood from my experience is that any controller connected to shield pro convert it into xbox360 controller as can attest joy.cpl or HidHide see below :

    Click image for larger version

Name:	HidHideClient_2021-11-28_09-12-20.png
Views:	572
Size:	5.9 KB
ID:	228669

    Click image for larger version

Name:	rundll32_2021-11-28_09-13-26.png
Views:	560
Size:	11.3 KB
ID:	228670

    Click image for larger version

Name:	rundll32_2021-11-28_09-13-40.png
Views:	569
Size:	16.5 KB
ID:	228671
    It works perfectly, my buttons are all recognized : Wonderful !
    But now as i explained it before, i want my controller to have the button share act as screenshot button (which is recognized as back on windows, the shield transformed it in xbox360 controller remember !).

    So after trying a lot of software, i finally found ReWasd which was promising and perfect for my attempt.
    I bought the complete pack to have all feature.

    Before we continue more far, i have to explain correctly my setup to your comprehension :

    My physical DS4 controller connected to -> 8bitdo adapter (Xinput mode) connected to -> Nvidia shield pro using nvidia app connected to -> my PC.
    At this point my controller is recognized as a xbox360 controller.

    So we continue :
    My xbox360 controller (which is a physical DS4 connected to 8bitdo adapter) connected to -> Rewasd with a custom xbox360 profile.
    What i did is simply apply F11 on back button of my controller and trying to apply a press on each analog sticks to do the real back function :

    Click image for larger version

Name:	reWASD_2021-11-28_09-37-55.png
Views:	650
Size:	430.5 KB
ID:	228672

    Sorry i have to make others post because i can attach only 5 thumbnails :

  • #2
    Hello! Have you tried using the "Take a screenshot" command? Maybe it will suit you.
    If this does not suit you, then we are waiting for the continuation of your post


    • #3
      Hi, thank you for your answer.
      Indeed i didn't know the "take a screenshot" command, it works great but the problem remain the same.
      Without the unmap feature, i have the same problem.

      Anyway this is the continuation of my post :

      Click image for larger version

Name:	reWASD_2021-11-28_09-38-00.png
Views:	671
Size:	269.1 KB
ID:	228677

      At first idk why but my controller seems to be not recognized by most of my games (indie game in particular).
      And i found a post on your forum that said that sometimes, some games doesn't recognized virtual controller and unmap function can help.

      So no problem, i disabled the virtual function in settings and when i apply my profile, i disabled the first xbox360 controller on hidhide to do not mess with games (i was used to this problem in past on DS4windows) :

      Click image for larger version

Name:	reWASD_2021-11-28_09-44-16.png
Views:	586
Size:	85.3 KB
ID:	228678

      Click image for larger version

Name:	reWASD_2021-11-28_09-46-13.png
Views:	626
Size:	414.3 KB
ID:	228680
      Click image for larger version

Name:	HidHideClient_2021-11-28_09-46-48.png
Views:	594
Size:	13.4 KB
ID:	228679

      Click image for larger version

Name:	rundll32_2021-11-28_09-47-11.png
Views:	559
Size:	12.2 KB
ID:	228681

      This time everything worked near perfectly.
      My screenshot button work as intended but not my double analog press to have my back button.

      After a lot of testing i didn't found a better solution than apply a keyboard key (tab in my case) and apply it on each game to make it work as back function.
      And finally here we go !!!
      All is working as attempt : Back button work as screenshot feature and double analog press as back function.

      It was working perfectly for 3 weeks and.................

      2 days agos, nothing changed.
      I connected my controller like usual on my shield.

      I launch a game and now my screenshot feature still work but the press on back now apply back + F11.
      Which is a mess for me...
      The button is still unmap, everything is like before but now my button doesn't want to be unmap at all.

      Another strange thing is, i now can apply virtual controller and all of my games recognize it.
      So i don't need to do the thing with HidHide like before.
      Nice except that my back button mess my screenshot fonction...

      I uninstall/install again the software but the version doesn't have changed at all since i first use it.
      I tried to understood if it was a Rewasd problem or on the shield side.

      My conclusion is i think it's a problem from shield because i tried rewasd with my DS4 controller connected directed to it.
      And all is working perfectly.

      Finally i tried to use moonlight on my switch to connect to my PC, it act like the shield and convert the joycon to xbox360 controller which is recognized by Rewasd.
      But it's the same problem again, back button act as screenshot and back.
      I didn't have a single problem with shield or moonlight app before.

      Do you think Nvidia did a thing in a update to mess all of this ?
      Can you try to use moonlight on your side and see if you can unmap a thing ?

      Soooo i hope your understood all of my explanation, as you can see i'm french so my english is far from perfect.
      But i hope you could help me on this problem !

      Thank you in advance !​


      • #4
        Hello! Please clarify, If you connect the controller directly to the PC and apply the config in reWASD, the button still does not work as it should?

        Check if you have the Advanced mapping feature active.

        Click image for larger version

Name:	D2PklQ6tByB5Xm.jpg
Views:	573
Size:	77.6 KB
ID:	228689


        • #5

          Yes if i connect it directly to my PC, it works perfectly.
          And yes i have the advanced mapping feature activated !

          As you can see below :

          Click image for larger version

Name:	reWASD_2021-11-28_18-14-16.png
Views:	608
Size:	50.3 KB
ID:	228703

          I really think it's something with nvidia gamestream.
          Can you try to use Moonlight and see if it works for you ?

          Thank you.


          • #6
            We tested Moonlight and didn't have any problems using it.

            We recommend not to disable the 'Hide physical controller when the virtual one is created' checkbox and use third-party applications for this.

            Could you please open joy.cpl (just type it in Windows search) and check if the click of the button to which the unmap is assigned is registered?


            • #7

              Okay i think you put your finger on something really interesting.
              First i ticked back the "hide physical controller when the virtual one is created" as you suggested :

              Click image for larger version

Name:	image_2021-11-29_184009.png
Views:	571
Size:	64.1 KB
ID:	228732

              I tried to only unmap the back button (without putting F11) like this below :

              Click image for larger version

Name:	image_2021-11-29_182944.png
Views:	595
Size:	423.5 KB
ID:	228730

              In joy.cpl : the button which is number 7 doesn't do anything as planned.
              I tried to play on 4 games :

              - ALTF4 : the button still work like if the unmap didn't do anything
              - Dreamscaper : the button still work like if the unmap didn't do anything
              - Code Vein : the button still work like if the unmap didn't do anything
              - Grime : For this game, the button is disabled as planned

              How it can be possible that windows doesn't see the button but the games does ?
              And why a game work as planned but not the others lol ?

              A big mystery if you want my advice :p !
              Attached Files


              • #8
                I'd like to clarify. Currently the controller chain seems to look like this:
                1. DualShock 4 controller connected to nVidia Shield Pro via 8BitDo dongle
                2. Moonlight's virtual Xbox 360 controller on PC
                3. ???
                4. reWASD virtual Xbox 360 controller on PC

                reWASD should be able to [Unmap] buttons and hide controllers on its own, though that might not work properly for virtual devices (2nd chain) and when 3rd party software/drivers that can somehow affect controllers are present in the system (3rd chain, ex.: HidHide, ds4windows, etc.).

                So I'd suggest disabling/removing anything that is 3rd party and try again, or to connect your dongle directly to PC and remap it like that.

                Though given how some games are able to ignore the [Unmap] flag, makes me think that they might be "listening" to the Moonlight's virtual controller instead of ours - somehow ignoring reWASD`s hide.. You can try to counter it by selecting our virtual controller as preferred in [joy.cpl], or by trying to use virtual Xbox One instead.