No announcement yet.

Right Stick/Triggers Not Working with FiveM

  • Filter
  • Time
  • Show
Clear All
new posts

  • Right Stick/Triggers Not Working with FiveM

    Remapping and everything works succesfully, have used my Xbox One controller several times, for some reason, if I leave it sitting for a bit, the right stick and left and right triggers stop working, The other key mappings still work, except for those which are essential for driving. I tried searching for a solution but the only one I found is Valorant specific, any help with this on FiveM?


  • #2
    The "if I leave it sitting for a bit" part suggests that power-saving functions might have kicked in.

    Please open [Device Manager] (type that into Windows Search), set [View] to [Devices by container], find your controller, then open every device inside and if they have [Power Management] tab disable [Allow to Turn off] option there.

    Click image for larger version  Name:	2022-02-08_23-06-47.png Views:	0 Size:	71.5 KB ID:	230162

    You might need to restart afterward for changes to take effect.


    • #3
      Hello, I have done this change that you suggested and still the same issue persists.

      If Remap is OFF, the controller works fine, if I turn Remap ON, the keybinds on the Dpad and XYBA buttons work, but the left and right stick dont and neither do the triggers.


      • #4
        Hey there!

        Could you please send the config you are using to check what exactly is mapped there? Pretty strange that some mappings stay active, but some not.

        Right-click on the name of the config you're using to open the contextual menu, and choose Open file location. Then send me the chosen *.rewasd file.


        • #5
          Thank you so much for the quick response, here is the Config I am using
          Attached Files


          • #6
            Thank you and sorry for the delay

            Your config includes the virtual controller, but I don't think you need it here. I have removed it, and I hope you won't experience the same issue with the config I've attached below.
            Attached Files


            • #7
              Thank you for the help, I gave it a test and seems to be working perfectly! Will try the rest of the day today and report back, I really appreciate the help!


              • #8
                Good news! You are welcome


                • #9
                  Thank you so much for the help, happy to report that removing the virtual controller completely fixed it, everything is working perfectly, thank you!


                  • #10
                    I'm having this same issue. How do you turn off virtual controller?


                    • #11
                      To turn virtual controller off, do one of the following:
                      • Use only [Native Mappings] in your config (requires Advanced Mapping feature);
                      • Disable the virtual controller via the [Magic Wand] menu on the [Gamepad] sub-config;
                      • Or select your physical controller as an output device in the [Magic Wand] menu.