No announcement yet.

I've noticed that my games minimize the first time I switch layers in-game. Help.

  • Filter
  • Time
  • Show
Clear All
new posts

  • I've noticed that my games minimize the first time I switch layers in-game. Help.

    I've been using ReWASD for years and this is the first time this has started happening. I've noticed that any time I switch to another layer after starting up a game it will minimize the game (or in the case of Far Cry 5 send me to the Start Menu screen), but the weird thing is it only happens the first time and then it works normally and doesn't do it again until the next time I boot up the game.

    Anyone know what ReWASD setting may be causing this, or how to fix it? This didn't happen before and it's relatively new behavior.

  • #2
    It might be related to the reWASD overlay or to the key you are using to switch layers (some 3rd party app might be reacting to it). You can try disabling the [Overlay] entirely or setting another key to switch layers or [Muting] the current one.

    Might be able to tell more if you would upload the config file you are using here.


    • #3
      Here's a dropbox link to my current Cyberpunk 2077 and Far Cry 5 profiles:

      (if it doesn't work)

      And the FC5 one:
      (if it doesn't work)

      I use a Razer Wolverine Tournament Edition controller. I map keyboard keys onto some of the buttons, as I like mixing together keyboard commands with native controller button inputs to achieve the config I want.

      Currently (for example) in Cyberpunk 2077 I have Left Stick Click-Button (push-in) set up as the button to shift to Layer 1 (red layer), and the problem that occurs is that when use it to access Layer 1 the game will minimize (sends me to desktop), now since the game is in Full Borderless then it isn't really a problem but it's still annoying. And yeah, I tried using Exclusive Fullscreen too.

      In Far Cry 5 I use the Left Bumper as the modifier, as that button opens the Weapon Wheel and I set it up so that when I have the WW open (and thus Layer 1 is active) the Right Trigger becomes the -> d-pad Right button, so I can use the RT to cycle through the Weapon Wheel options by using the RT instead of moving my thumb to the d-pad. Of course there are also other remappings but in the case of FC5 it only happens when I use the Left Bumper, i.e. when I go into Layer 1 shift, and instead of minimizing what it does is that it opens the game's Start Menu screen.

      Things I've done to troubleshoot: tried already disabling overlay, no change in behavior for either game. Also tried putting both games and ReWASD in Administrator mode, no luck either.

      Next thing I'm going to try now is I'm going to last year's Rewasd, the one just before v. 6.x.x.x, and see if it happens with an older build. I'll report back if it happens with the older build too, or if the older build works.


      • #4
        EDIT: Oh I've tried setting different buttons as the Layer 1 shifter, the minimizing/Start Menu opening still happens regardless, but it ONLY happens when a Shift button is pressed... and it only happens once per session, like I said after it happens one time then it stops happening until the next time I launch the game.


        • #5

          So I tired the older 5.8.2 build, the one just before moving to version 6.x.x, and the problem never happened again. I played both games and used the Shift button as much as possible, spamming it even, and the games never minimized once.

          I did this because I suspected it had to do with the new build of the app, since like I said: I've used ReWASD for years and this has never happened before. It only started happening recently.

          It may have something to do with how version 6 allows you to use multiple buttons as Shift modifiers for the same layer? I dunno, just that I noticed that version 5.8.2 only allows me to have 1 single button shift to Layer 1 at a time, unlike version 6 which let me map several.

          I'll report back if it starts happening again but for now I'll stick to 5.8.2.


          • #6
            Thank you for the information and configs you provided. We have forwarded them to our testers. Please stay tuned.


            • #7
              Ok, after some more days of testing I have some new findings:

              Version 5.8 still exhibits the same problem, so it isn't related to the big 6.x update, or the new overlay stuff. Cyberpunk 2077 (only game I'm currently playing) still minimizes sometimes when I press whatever button I have set to Shift into Layer 1.

              Things I've found out:

              1. Version 6 wasn't the culprit, 5.8 does it too.
              2. I've tested with different controllers, so that rules out the Razer Wolverine as the culprit. Regular Xbox One controller in use and it still happens.

              And most importantly: I think I've got it narrowed down to the Left Bumper as the main thing to trigger it. Right now I have START (or what Xbox calls 'View') button set as my Shift button into Layer 1, configured to Shift when It's depressed (held down).

              And I've noticed that I can almost always trigger the minimize by first pressing Left Bumper right before pressing the Shift button (START in this case, though it doesn't matter what it's mapped to). I need to continue testing to see if it's always triggered by the Left Bumper usage. And as I wrote in my previous message, in Far Cry 5 where I had the Left Bumper as my Shifting button the game would enter into its Pause Menu (instead of minimizing) when I Shifted into Layer 1.

              I've also tried turning off all of the Taskbar functions in Windows 10, such as the 'Peek' function, since I thought maybe that could have something to do with it, but it still minimizes with it disabled.


              • #8
                I wanted to add, in case it wasn't clear, that while it does happen often it's not something I can trigger every single time, which is why it's only an annoyance and not a real problem. Sometimes I can go several hours without having any trouble with the Shift/Layer 1 button, then all of a sudden it will cause the game to minimize when I press it. It's mostly random as to when it happens.


                • #9
                  Since this phenomenon does not have clear steps to reproduce and patterns, it can be assumed that these clicks trigger something in your system and cause this behavior.

                  If you're playing on Steam, make sure that Steam controller support, including Xbox extended feature support, is turned off in Steam Big Picture mode.

                  Check if your PC has other programs or drivers for remapping (SCPtool, DS4Windows, hidhide, hidguardian, etc.)

                  As a last resort, if you have such an opportunity - check the same configs in the same games but on another PC.
                  Or perform a clean reinstallation of Windows OS without installing unnecessary software and see if you can reproduce this issue.

                  It would be a little easier for us to deal with this if there were clear steps in which the issue is 100% reproduced.


                  • #10
                    OK, can do.

                    - I'll make sure Steam controller config is disabled (already did), I'll go the extra step to make sure Steam is off while I'm "testing".

                    - I'll also do a Windows re-install, because funnily enough I just did a re-install a few days ago and that's a new variable; in my previous Windows the minimizing thing didn't happen. So anyway yeah I'll re-install.

                    No other controller programs, besides Steam and I'll make sure it's disabled.

                    Can't test on another PC though, but I also found one more variable that is new that might be causing the behavior:

                    - recently I started grouping together the controller + kb + mouse in all the ReWASD configs, and this is not something I used to do before, it's something I started doing recently... and the minimizing-on-Shift started happening recently too, So to make sure it has nothing to do with it, I'll be "testing" (playing and spamming the Shift button) with everything ungrouped like I used to have it before, when I never had any problems.

                    Don't even remember why I grouped everything together to be honest, I think it was because I wanted to do a combination of kb and mouse for some activation and decided 'might as well group the controller too', anyway I'll ungroup everything to see.


                    • #11
                      Oh and I also cleared the ReWASD data cache, which I hadn't done before. See if that helps. I'll report back in a few days.


                      • #12
                        Great! We appreciate your desire to solve this issue and your cooperation


                        • #13
                          Well, I finally found out the cause: it was having all of my peripherals grouped together on every profile. As soon as I ungrouped everything the minimize-on-Shift problem has completely disappeared AND it solved another problem I had been having where ReWASD wasn't attaching to a game .exe on first launch, and I had to alt-tab to make it enable the auto-apply config.

                          I also cleared the ReWASD cache, so it is POSSIBLE that this alone solved it, but considering that ungrouping the peripherals also solved the auto-attach problem I'm leaning towards that being the cause. I only started grouping every peripheral together recently, and like I said before I honestly can't even remember why... I just did it because I could, I guess, and it was right around then that the minimize-on-Layer-Shift problem started happening. I had never before used the grouping feature in my years of using ReWASD, so it fits the timeline of when the problem started, and the auto-attach problem also started recently as well.

                          This'll probably be my last post on this thread then, I think it's definitely solved. Thanks for the attention on the thread!


                          • #14
                            We are always happy to help. And we are very glad that the problem was solved!