No announcement yet.

Custom Mouse Mappings Disappearing

  • Filter
  • Time
  • Show
Clear All
new posts

  • Custom Mouse Mappings Disappearing

    I've tried multiple times with multiple layouts and my custom mouse mappings keep disappearing. Sometimes they work but aren't visible but as soon as I reapply they are lost. This has only been since the 6.3 update. I've tried completely rebuilding and it still is occasionally an issue. I am also getting frequent errors that profiles can't be applied due to too many bindings or combos, even when there aren't that many. Sometimes completely exiting and reopening the app helps, sometimes not. Please help! I'm a huge supporter of the app and just bought the mobile mapping add on, but this kills the whole purpose for me.

  • #2
    Please make sure you are using the latest version of reWASD (, and if not, download and install it from our site or your personal account.

    If you are already using the latest version or the issue persists after the update try using the [Clear data] button at the [Preferences > General].

    If that won't help either, please provide us with the config file that you are using and video or screenshots where all these errors and issues would be visible.


    • #3
      It was on the latest version and the issue persists. I think I've found a work around though. The problem seems to reproduce only when I'm using a device grouping that includes the mobile controller in any of its forms in addition to a physical gamepad and mouse.

      I've since removed the mobile gamepad from all my configs and not had a problem since. Although this is not ideal, since I paid for the mobile gamepad functionality. Here is a copy of a config file with it added back in. At the time I'm uploading, I am able to see all the mouse mappings fine. But if the pattern holds, after applying and switching profiles a few times, they will disappear.

      Weirdly, in trying to force this like it was happening before, if I clone this profile, instead of losing the mouse mappings like it did before, now its dropping the second gamepad for the mobile gamepad. Something isn't right here...
      Attached Files


      • #4

        I've tried to reproduce the issue from my side. I didn't have this problem.
        I would appreciate it if you could record a short video of how it going on

        Thank you in advance!