Announcement

Collapse
No announcement yet.

Keyboard and mouse won't work after turning on/off Rewasd

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Keyboard and mouse won't work after turning on/off Rewasd

    Hello, this is the main problem since I started using the app this month. Sometimes after some hours playing, and turning on/off Rewasd several times to be able to go to desktop, or surf the web or whatever, the keyboard eventually stops working correctly. If I type something in discord, or chrome it starts to open menus, or runs the developer tool for chrome (like if some key remains pressed), so I have to open task manager and kill the app. But today even killing the app in task manager didn't help, I had to restart my PC for the keyboard to work.

    The other problem is that my secondary keyboard/track pad (wireless) worked great for like 2 days and now behaves like the problem mentioned above, I mean I didn't have to turn off Rewasd because I have that secondary keyboard I used to go to desktop, but after 2 days of installation it doesn't type anymore, it opens menus and stuff, so the same fix turn off the app or kill it in task manager.

    I use a confing downloaded from here and slightly modified by me.

    Sorry for the bad english.
    Attached Files

  • #2
    Hello

    This is extremely weird behavior. I didn't get similar reports before. reWASD doesn't work with the internal memory of the device and all mappings should be off as soon as you Turn remap OFF.

    However, I a little modified your config. You can use the native input of your keyboard without Turning to remap off/on now. Just click on L win and you will switch between two inputs easily and will be able to type something in discord, chrome, etc. Tap again to switch to the controller mode.

    Check this article for details.‚Äč


    Attached Files

    Comment


    • #3
      Thank you very much, I'm going to test the config.

      Comment


      • #4
        I think there is something wrong with the "Shift 2 Layer". When I use L win, all the keys used for maping won't work. So I can't type WASD or anything using game keys, only the keys that are not used in the mapping can be used to type, like J or H
        How can I fix that? I tried deleting them but it didn't work

        Comment


        • #5
          Checked the config from post #2 and Shift#2 works exactly as it should: all keys remapped on the main shift have the "Do not inherit" mapping set on the 2nd shift and work natively.

          If they are not in your case, then you are not on the 2nd shift at the moment. You can use Overlay to check what shift layer you are currently on.

          Comment


          • #6
            I have overlay active, once I press L win it changes to green and says "Shift 2 layer is active", but WASD and all the keys used in the mapping don't work.

            Comment


            • #7
              Can you make a video where all of the following would be visible:
              • group editor
              • reWASD window with the config you are using
              • overlay showing the currently active Shift layer
              • Gamepad Tester showing virtual controller inputs
              • Notepad showing virtual keyboard inputs
              Apply the config, switch to Shift#2, and try typing something in the notepad.

              Comment


              • #8
                Ok, I will try but now the app doesn't light up the icon for turn it on/off, is grayed and it doesn't let me tur it on. I started to clic it like a maniac and at some point it turn on but with no way to turn it off again, so I had to kill the app in task manager.
                I'm going to reinstall, I hope it helps.

                !!EDIT!!
                Reinstalling helped and it seems that all problems are fixed, I mean I can type now, layer is working ok. I hope the problem with the keyboard blocked even with the app off is fixed too.
                Last edited by oooooIEC; 25.09.2022, 00:54.

                Comment

                Working...
                X