No announcement yet.

Virtual controller mappings no longer working on MW2 PC Steam

  • Filter
  • Time
  • Show
Clear All
new posts

  • Virtual controller mappings no longer working on MW2 PC Steam

    I've been using REWASD virtual controller mappings for Warzone on PC Steam edition for months with several different physical controllers (XB Elite, Dualshock 4, and Gulikit) all primarily mapped to Virtual DS4. These same settings worked fine during the new MW2 beta, campaign, and first day of full release all for the Steam edition.

    Suddenly, today, no virtual mappings for the Gulikit will work at all except for XB1. The controller actually identifies as Xbox 360, but even that as a mapping won't work. The actual game, MW2, immediately recognizes the virtual DS4 mapping, as the in game controller diagrams immediately switch back and forth to Sony vs Xbox pending the rewasd virtualization, but it won't recognize anything.

    The only thing I know I've done is that I briefly tried turning on Steam's own gamepad input option and trying a DS4 map via that, but the default response curves etc were horrible and I immediately disabled it. I *think* the rewasd has worked since then, but I could be wrong. I've switched that on and off, restarted everything, switched Gulikit input modes, nothing works. It now refuses any virtualization other than XB1.

  • #2
    Could I ask you to check how our virtual controller works for Warzone? As I understand the issue is only related MW2.


    • #3
      Same situation now in Warzone via Battlenet. The mappings worked fine before, now DS4 does nothing.


      • #4
        I'm afraid there is not enough information to assume anything else but those games not accepting DS 4 controllers or specifically our virtual DS4 anymore for some reason.

        I suggest checking whenever remapping works on its own at [Gamepad Tester] first: apply the config, open the site, check all buttons and sticks.
        Then check how many controllers are visible to the system before and after the config is applied in Windows Game Controllers tool [joy.cpl].

        If you have installed some kind of remapper lately (ds4windows) or software that can emulate controllers (Parsec, x360ce, VigemBus, SCPToolKit), you should uninstall those, as they are known to interfere with normal reWASD operations when misconfigured.


        • #5
          No other software has been installed since working. The absolute only other thing was Azeron's software for the cyborg, but the Gulikit rewasd virtualizations worked perfectly following that, as it had since I received it. No cheats, not even any other games or software. Strict Asus gaming laptop. The only thing was enabling the steam controls briefly on MW2 and I also had a nice mouse plugged in several times, but I know it worked since that, as that was part of Azeron. The only thing I'm not sure if is whether I had the mouse plugged in with MW2. I double checked the in game mouse vs controller though, and it's not just the aiming stick, and the problem doesn't apply to xb1 virtualization as I was saying. I'm going to go try other games and see if they work ( I haven't as of yet) and check the tester youentioned!


          • #6
            I'm having this same problem. If I restart my computer (and reWASD loads) MW2 wont recognize my Xbox Elite Series 2 controller which has a virtual controller profile created via reWASD for 7 Days to Die.

            I have to quit the reWASD app, remove all controller related devices from the Bluetooth devices section in Windows Settings including the XBOX wireless adapter and the virtual controller reWASD creates. Then I physically remove the XBOX wireless adapter. I can then reattach the adapter to the PC and pair the controller to the adapter and it'll work in MW2. From there I can open the reWASD app and all functionality is restored and the controller works in MW2 including the virtual controller keys if I switch to that profile. This setup will work for several days (until a pc restart) even with quitting the MW2 game and restarting it.

            So I don't think it's the game not accepting the DS 4 Controllers, or specifically the Virtual DS4 but something else is glitching out.


            • #7
              I think the first thing to do is to make sure that everything works according to the tips that Shion described.
              If there are no third-party remappers on the PC, controller support is disabled on Steam and everything works fine for testers and other games, then most likely there is some kind of problem in the interaction of the virtual controller with the game itself. And there is hardly anything we can do


              • #8
                Tuve un problema similar hace tiempo, siempre juego con el modo xbox pero un dia no me reconocia el mando, cambie a modo DS4 y ya funciono, al dia siguiente todo vuelta a la normalidad, si es raro