Announcement

Collapse
No announcement yet.

Keyboard commands set to repeat/turbo are choppy / laggy / occasionally dropped.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Keyboard commands set to repeat/turbo are choppy / laggy / occasionally dropped.

    Hi guys, bought ReWASD today and I've fallen at the first hurdle, if you can help I'd really appreciate it
    I'm configuring ReWASD to run Hyperspin front end menus with an xbox 360 controller, emulating keyboard.


    ISSUE: Keyboard commands set to repeat/turbo are choppy / laggy / occasionally dropped.

    To illustrate: if I set keyboard key 'X' to repeat every 300ms, I'm hoping to see this:
    X......X......X......X......X......X......X......X ......X......X......X......

    But what I get is this:
    X........X...X.......X......X..X....X.....X....... ....X........X..X...........

    ReWASD tweaks:
    -Tested with different timings, 200 to 2000ms
    -Tried all ReWASD 'repeat' methods (Turbo / Combo + pause + break / Combo + iterations + pause)
    -Tested with commands assigned to xbox 360 buttons, sticks and triggers. Same outcome.
    -Muted all
    -Tried running ReWASD High Priority in explorer

    Other info:
    -ReWASD config seems to work perfectly in games/programs other than Hyperspin
    -No other controller program having this issue in Hyperspin (Xpadder, Pinnacle, Steam, Controller Companion)
    -No conflicting controller program is running, and Hyperspin is set to ignore native controllers
    -Tried running Hyperspin in full screen / windowed mode

    Running W7x64
    ReWASD 6.3.2.6821

    Any ideas? Thanks for your help!

  • #2
    Hello!
    Please record the problem on video. This will help us a lot.

    Also send your config.​ You can find your config by right-clicking on the profile name and open the file location.

    Click image for larger version

Name:	image.png
Views:	65
Size:	48.7 KB
ID:	234389

    Comment


    • #3
      Thanks for your help! Keen to fix.
      As requested:
      • Video: exceeds size, so I uploaded here as a gif: https://ibb.co/p297vGw
        Video events: ReWASD activated, Hyperspin.exe launched, JoytoKey terminated.
        Dpad up held, sends Keyboard 'Up' w/turbo @500ms.
        Output timing varies between 200-800ms, drop some altogether.
      • Config: attached.
      -As I mentioned, this chop/lag does not occur with other controller programs. JoyToKey / Xpadder / Steam / Pinnacle all send with perfect timing.

      -Also strange is that the ReWASD turbo/combo+pause timing is perfect in other apps tested (Excel, Notepad, Desktop, Game: Far Cry Blood Dragon)

      Thanks!
      Attached Files

      Comment


      • #4
        Thank you! We'll try this on our side and get back to you with the results.

        Though I can already tell that a button with a [Turbo] flag enabled is held for quite a small time (usually under 20ms).
        And there is a possibility that this game might be ignoring any keypresses, that are under 17ms long (if the game is running at stable 60fps).

        A potential solution would be to replace the key mappings with a Combo of the same key held for at least 20ms as in: [Key down] [Pause 20ms] [Key up]

        Comment


        • #5
          Originally Posted by Shion View Post
          there is a possibility that this game might be ignoring any keypresses, that are under 17ms long
          This would explain the 'drops' but not the shorter 'chops', ie when two presses occur with shorter timing than programmed.

          Originally Posted by Shion View Post
          A potential solution would be to replace the key mappings with a Combo of the same key held for at least 20ms as in.
          I'll try this. How do I 'repeat while held' including the pause, as in [Key down] [Pause 20ms] [Key up] [Wait 300ms] [Repeat]?

          Comment


          • #6
            Originally Posted by JimJams View Post
            I'll try this. How do I 'repeat while held' including the pause, as in [Key down] [Pause 20ms] [Key up] [Wait 300ms] [Repeat]?
            Enable the [Turbo] flag for this [Combo] mapping.

            Comment


            • #7
              Originally Posted by Shion View Post
              Enable the [Turbo] flag for this [Combo] mapping.
              Thanks Shion, making some progress. Results are still a little choppy but improved with Pause >20ms, so it appears the problem might be related to 'key held' duration <20ms.

              This is unexpected because Hyperspin reliably behaves itself with 'key held' duration set as low as <11ms in other controller programs.

              I'll have a play to see if I can smooth out performance further and report back.

              Comment

              Working...
              X