Announcement

Collapse
No announcement yet.

Mapping not working.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mapping not working.

    Hi everyone. I have included as many images as I thought would be apt as well as my config file. I'm using reWASD with Skyrim. Everything seems to be set correctly and when the game begins, I get a notice that reWASD is activated for the game, but when I'm in-game, it's just the default settings. None of my reWASD settings work.
    Attached Files

  • #2
    Hey there!
    Your config contains keyboard and mouse mappings, which shouldn't be a problem.
    Try turning off virtual controller emulation.
    To do this, click on “Magic Wand” and then turn off the virtual controller.
    Click image for larger version

Name:	image.png
Views:	2707
Size:	555.0 KB
ID:	235079
    Then check if the mappings work outside the game (for example, in any text editor).​

    Comment


    • #3
      Hi, Thank you for responding. I turned off virtual mapping and realized I couldn't use my keyboard to type. I selected notepad with the mouse and tried to keyboard type and couldn't. I was able to press some buttons on the game pad and it tried to open various windows menus.

      Comment


      • #4
        reWASD should not affect your physical keyboard in any way unless you have applied config to it.
        In your screenshots, I see that the configuration is only applied to the Elite 2 controller. Therefore, once again, make sure that the config is applied only to the gamepad and that your physical keyboard is not in the group with the gamepad.

        You can try pressing Ctrl + Alt + Delete (this should turn off remapping from all devices) and then reapply the config to your controller.

        If the problem persists, try recording it on video.​

        Comment


        • #5
          I should also note, that when I plug the controller in I also get a notice saying that Steam is using my steam configs. Not sure if those supercede reWASD settings. If so, not sure how to completely get rid of the Steam settings.

          Comment


          • #6
            Originally Posted by witchkissed View Post
            I should also note, that when I plug the controller in I also get a notice saying that Steam is using my steam configs. Not sure if those supercede reWASD settings. If so, not sure how to completely get rid of the Steam settings.
            Open Steam Big Picture mode and disable support for your controller. Also turn off Xbox Extended feature support. After that, you will need to restart your PC.

            Comment


            • #7
              I turned off all of the Steam controllers. I didn't have Big picture mode on. I restarted my PC and the mappings still aren't working.

              Comment


              • #8
                1. Try to record the problem on video.
                2. Open Steam Settings → Controller → General Controller settings. A window will open in the Steam Big Picture. I need a screenshot of it.​

                Comment


                • #9
                  Here is the screenshot.
                  Attached Files

                  Comment


                  • #10
                    You should uncheck all boxes, including the first one.

                    Comment


                    • #11
                      I've unchecked it as well. I'm still having the same issue. Is there anything else it could possibly be? Maybe some setting I have incorrect in reWASD? I made a blank profile as was suggested and I have the correct slot on my controller as I do in reWASD.

                      Comment


                      • #12
                        Everything seems to be set up correctly. Try reinstalling reWASD following the steps below:
                        1. Uninstall reWASD via Windows apps & features
                        2. Restart your PC
                        3. Install the latest version of reWASD from the website
                        4. Restart your PC again.

                        If after reinstalling, the problem persists, try recording a detailed video of your issue.​

                        Comment


                        • #13
                          Ok, I will try that. Thank you.

                          Comment


                          • #14
                            Try this:
                            In ReWASD Settings go to Gamepads section and make sure "Hide physical controller when virtual one is created" is checked, and save/apply the change.

                            You may have to click around a bit or restart your game/Steam, but that may help. I was having the same issue with Destiny 2 not recognizing my paddle mappings. This fixed it for me, allowing Destiny to detect my normal controller inputs as well as my paddle remaps.

                            Comment


                            • #15
                              Thank 1ncorrect​ for help​

                              Comment

                              Working...
                              X