Announcement

Collapse
No announcement yet.

Keyboard being recognizes as mouse and keyboard

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Keyboard being recognizes as mouse and keyboard

    My k70 corsair is being recognizes as keyboard and mouse. So i cant use my mouse to emulate the directions. Only the buttons work (ex: to aim or to fire).

    Can someone help?

  • #2
    Hey there!
    To fix it, please follow these steps:
    1. Ungroup the Keyboard and Mouse, so all the devices are shown separately in the bottom left corner of the main window.
    2. Use Detection mode to find the correct Keyboard and Mouse. If you press the mouse button but see the keyboard in reWASD, then you will need to re-initialize it (from the contextual menu of an active device): https://help.rewasd.com/interface/device-detection.html
    3. After you are sure about all the devices, please group Mouse and Keyboard and try to Apply your config and test it in joy.cpl or in a game‚Äč

    Comment


    • #3
      Hello!

      I've tried, but the reWASD still recognizing the keyboard as keyboard + mouse (even the icon on the bottom left corner shows it). =((
      I make a test with another keyboard, but the problem still remain.

      is it possible because i running the trial version?

      Comment


      • #4
        We have to make it clear that your keyboard is not recognized as a keyboard and mouse, but identifies as a composite device with functions of both a keyboard and a mouse.

        If you want to remap it as a keyboard, you are required to initialize it as one according to the instruction strokel provided above. The resulting group should look like this (pay attention to the icons):

        Click image for larger version

Name:	2023-01-18_2-34-01.png
Views:	44
Size:	3.8 KB
ID:	235246

        Note: the Trial Period is not related to this case in any way.

        Comment


        • #5
          I followed all the instructions and the problem was still there. Maybe the mapping i was trying to use had some blocked configs by the trial version. I dont know what was wrong.
          But now i got the license and its working well.

          So problem solved!

          Anyway ty guys for the support!

          Comment

          Working...
          X