No announcement yet.

Hook controller buttons no longer working

  • Filter
  • Time
  • Show
Clear All
new posts

  • Hook controller buttons no longer working

    I use ReWASD to remap buttons on a Xbox Adaptive Controller using an Logistic Adaptive Gaming Kit, so the layout doesn't exactly match regular Xbox controller layout. In the past, while ReWASD is open, when I would physically press a button, a little menu would pop up allowing me to remap that specific button. I think this feature is called "Hook controller buttons" in the preferences, but maybe I'm mistaken. This feature was crucial to make it easier to remap, since the Logitech switches do not easily map to normal buttons.

    Anyway this feature has stopped working. I haven't used this in about a month, and when I revisited today I was prompted to update. I've tried reinstalling, restarting my PC, and it still doesn't work. I'm using ReWASD version

    I think ReWASD is successfully remapping buttons when I apply a configuration, it's just this convenience feature that seems to not work

  • #2
    This is not a bug. reWASD is working as intended in this regard.

    Since the [Hook controller buttons] option was involved in numerous cases of accidental changes to the configs, which remap controllers to keyboard keys, we decided to disable it in reWASD UI when remap is enabled for the selected controller. So if you want it to work - disable remap for the selected controller first.


    • #3
      Great, thank you for the fast reply!