Announcement

Collapse
No announcement yet.

XBOX 360 Controller does nothing when reWASD is on

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • XBOX 360 Controller does nothing when reWASD is on

    Trial-ing reWASD but struggling to use it. I guess I don't understand the basic configuration. I have a working Xbox 360 controller with Project64, and wanted to add a "swim fast" by mapping Y button to a cycled A button, but even with mapping nothing, there's no controller response at all within Project64 if reWASD is on. I'm not understanding all the terminology, either. Is there a way to have reWASD still make the controller work "as is" and then I can try to tweak more buttons? Project64 works fine with my controller, I just wanted to map unused buttons to something useful.

  • #2
    Hey there!

    Please send screenshots of how your controller is displayed in reWASD and joy.cpl.

    Also, please send a screenshot of the full reWASD window with your controller mappings.

    Comment


    • #3
      Thank you, sorry I haven't responded sooner. I'm hoping this is what you're asking for:

      Click image for larger version

Name:	2023-05-16_19-39-11.png
Views:	264
Size:	609.6 KB
ID:	237154Click image for larger version

Name:	2023-05-16_19-40-35.png
Views:	260
Size:	14.1 KB
ID:	237151Click image for larger version

Name:	2023-05-16_19-40-23.png
Views:	258
Size:	16.3 KB
ID:	237152Click image for larger version

Name:	2023-05-16_19-40-55.png
Views:	254
Size:	8.9 KB
ID:	237153
      Attached Files

      Comment


      • #4
        Could you try to turn focus mode off and look at how your config work here?

        Comment


        • #5
          Is this what you're looking for?

          Click image for larger version

Name:	2023-05-16_21-44-03.png
Views:	252
Size:	154.2 KB
ID:	237158
          Attached Files

          Comment


          • #6
            1. Judging by the screenshots from the tester, you did not manually apply the reWASD config. Turn off Autodetect and apply the config using the "Apply to slot" button. Does the virtual controller respond to your button presses on the site?

            2. Please send another general screenshot from joy.cpl showing how many controllers the system detects. (The reWASD config must be applied at this point)

            3. Project64 is a Nintendo64 emulator. I'm not sure why the emulator works with your Xbox 360's native input, but you should try to change the reWASD virtual controller type to Nintendo Switch. This does not guarantee that the reWASD virtual controller will work, as the input of the Nintendo Switch and N64 is different. But you should try it.‚Äč

            Comment


            • #7
              I appreciate the help, I got it working but not sure why as I thought I did all the things you suggested before. There's still only one controller showing up in you.cpl. I do see a switch controller in reWASD I haven't tried yet. Below are the steps I went through when suddenly it started working. Maybe it was the testing under reWASD? Also, the repeat, for some reason, still doesn't always fast-swim, and I tried many different speeds. It seems to lose cadence when I steer. Would emulating the Switch actually work better? Fast speed requires consistent strokes, which I'm unable to achieve on the Project 64 emulator but I have no issues on the original N64 with Nintendo's controller.

              This is what project 64 (v4) shows (it just works):
              Click image for larger version

Name:	2023-05-18_14-36-22.png
Views:	277
Size:	65.4 KB
ID:	237233

              I turned off autodetect (assuming this is what you mean since I don't see a name, just help text):
              Click image for larger version

Name:	2023-05-18_14-38-18.png
Views:	228
Size:	22.7 KB
ID:	237236

              After hitting Apply to Slot1 I didn't see any new controller show up in joy.cpl, even after reloading it:
              Click image for larger version

Name:	2023-05-18_14-43-28.png
Views:	227
Size:	12.2 KB
ID:	237237

              One other thing I noticed. When I apply config, I get a quick popup:
              Click image for larger version

Name:	2023-05-18_14-48-25.png
Views:	227
Size:	9.9 KB
ID:	237234

              It took me quite a few tries to realize I needed to press all buttons at the same time. Sure enough, it flickers A when I hit Y (will need to tweak the speed of course), and all other buttons just work. This is the mapping in the config:
              Click image for larger version

Name:	2023-05-18_15-05-11.png
Views:	234
Size:	109.9 KB
ID:	237235

              Comment


              • #8
                I got "fastest" fast swim working too. There's a combo of down and up that matters and I was able to achieve it using combo and turbo at the same time. Combo delay from down to up of 633ms and turbo repeat of 33ms (this gets pretty close to ideal 90bpm or 667ms total round trip.
                Click image for larger version

Name:	2023-05-18_16-22-18.png
Views:	247
Size:	102.9 KB
ID:	237239Click image for larger version

Name:	2023-05-18_16-22-06.png
Views:	226
Size:	431.7 KB
ID:	237240

                Comment

                Working...
                X