No announcement yet.

Ps5 controller won’t connect any more

  • Filter
  • Time
  • Show
Clear All
new posts

  • Ps5 controller won’t connect any more

    Had rewasd working fine with a PS5 controller for a few days….But then the PC connected controller shuts off after connecting to PC. Tried disconnecting controller in windows Bluetooth settings and connecting another controller but still not working. Tried 2 controllers and and resetting controller with the reset button/holes

  • #2

    Hey there!

    ​Could you please clarify if this happens without reWASD?

    Also, please send us a screenshot of joy.cpl with the controller connected by wire, in wireless mode, and with the reWASD config applied.​


    • #3
      I believe it started when I tried to either use the external device setting or App detect button. But anyway the controller connects to the PC then acts like the battery runs out and shuts off within a few seconds. I have tried 2 controllers and they both do the same thing. If I use the remove device and add it back it still does the same thing in Windows 11. I tried the troubleshooting Bluetooth but it didn’t help.

      BUT if I uninstall Rewasd I can remove the controller in Windows Bluetooth settings and add it back then the controller connects and works in game. Once I reinstall Rewasd it starts disconnecting again after the Rewasd install/pc restart. I tried both uninstalls where it does or does not remove all settings. No luck. I’ve been trying to get it to work all week.


      • #4
        Okay maybe never mind. (Hopefully) After deleting everything once again including the virtual controller in Windows Bluetooth it has started working again. I’ll just have to re-input my controls.


        • #5
          This behavior needs to be studied. If the problem occurs again and your steps to resolve it don't work this time, please let us know.
          Then we need some information.​


          • #6
            Will do but I’m just not going to try new strange things with Rewasd for a while if it’s working untill I get some use out of it. I have a feeling it was from using the PS5 controller plus mouse and trying to use it external to my iPhone.


            • #7
              If so, we'll be here to help you.


              • #8
                Okay, I have had problems every night I have tried to play with Rewasd and I figured out a little. I have had to mess with this more than I have played. But anyway sometimes it starts working but I’m not sure why after I mess with it for a few hours but nothing repeatable. Usually the PS5 controller connects and the blue lights just go out like it goes to sleep and the controller is unresponsive no matter what I do until I either hold the PS button down until it shuts off or I disconnect in Windows 11.

                However, if I stop the Rewasd Game Controller Mapping Service the controller connects fine with the white led showing up in game and I can use the standard controls in games. I can not use with Rewasd even if I restart the controller mapping service one I connect this way though.


                • #9
                  Please run reWASD, then plug up your controller and show me how it shows in reWASD GUI