Announcement

Collapse
No announcement yet.

Unable to map single click of microphone button for DualSense

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to map single click of microphone button for DualSense

    When I set up mappings for double-click or long-press of the microphone button, everything works fine.

    However, the mapping set on the single click alone does not work properly. After I press the button, it doesn't have any response.

  • #2
    Could you send a screenshot of this mapping?

    Comment


    • #3
      Originally Posted by 1ncorrect View Post
      Could you send a screenshot of this mapping?
      This is my key mapping configuration. I turned Alt+F1 into a macro and assigned it to a single click, and I added a vibration for confirmation.

      I found that mapping for single keys can take effect, except for macros. At the same time, I can confirm that this macro, when placed on a double-click, functions properly when held down.

      Click image for larger version

Name:	Snipaste_2023-08-30_17-22-53.png
Views:	165
Size:	1.06 MB
ID:	239028

      Comment


      • #4
        Hi. Please try to map any button on the controller to this microphone button on Single press activator, and check if it works in the tester: https://hardwaretester.com/gamepad

        Also, please ensure you apply the config to the correct device. You can detect the device you are using using Device detection mode.

        Comment


        • #5
          Originally Posted by strokel View Post
          Hi. Please try to map any button on the controller to this microphone button on Single press activator, and check if it works in the tester: https://hardwaretester.com/gamepad

          Also, please ensure you apply the config to the correct device. You can detect the device you are using using Device detection mode.
          The test is consistent with the situation I reported.

          When I map it to the 'O' key, every time I press the microphone key, the corresponding button on the test page will flicker.

          Click image for larger version

Name:	work.png
Views:	154
Size:	1.13 MB
ID:	239050
          When I map a macro, regardless of what it is, the buttons on the test page do not respond at all.

          Click image for larger version

Name:	not work.png
Views:	140
Size:	1.15 MB
ID:	239051
          Even if I map a single 'O' key as a macro, the corresponding 'O' key on the test page still does not respond.

          Comment


          • #6
            We would like to get some logs for us:
            1. Run reWASD as Administrator: right-click reWASD icon or shortcut and choose Run as Administrator
            2. Allow reWASD to make changes to your device.
            3. Now open Preferences and click Start log in the lower left corner, then close Preferences window
            4. Complete the steps you were having trouble with
            5. Open Preferences again and press Stop log
            6. Choose Open file location to proceed to the folder
            7. Choose the archive that was created last and send it to us.​

            Comment


            • #7
              Originally Posted by strokel View Post
              We would like to get some logs for us:
              1. Run reWASD as Administrator: right-click reWASD icon or shortcut and choose Run as Administrator
              2. Allow reWASD to make changes to your device.
              3. Now open Preferences and click Start log in the lower left corner, then close Preferences window
              4. Complete the steps you were having trouble with
              5. Open Preferences again and press Stop log
              6. Choose Open file location to proceed to the folder
              7. Choose the archive that was created last and send it to us.​
              I have mapped Alt+Z as a macro to the microphone key, but they still don't work properly. Here is the log.
              Attached Files

              Comment


              • #8
                Before I pass the logs to the team, I would like to clarify one thing.
                Do you have this option enabled?​
                Click image for larger version

Name:	image.png
Views:	148
Size:	91.1 KB
ID:	239087

                Comment


                • #9
                  Originally Posted by 1ncorrect View Post
                  Before I pass the logs to the team, I would like to clarify one thing.
                  Do you have this option enabled?​
                  Click image for larger version

Name:	image.png
Views:	148
Size:	91.1 KB
ID:	239087
                  Yes, most of them are default settings.

                  Click image for larger version

Name:	Snipaste_2023-09-02_13-01-21.png
Views:	136
Size:	75.4 KB
ID:	239092

                  Comment


                  • #10
                    As we can see from your screenshot, the tester shows one more controller besides our virtual one; it shouldn't be like that.
                    Please make sure that there are no third-party remap programs on your PC.​

                    Also, please ensure that controller support is turned off in the Steam controller settings.​

                    Comment


                    • #11
                      Originally Posted by strokel View Post
                      As we can see from your screenshot, the tester shows one more controller besides our virtual one; it shouldn't be like that.
                      Please make sure that there are no third-party remap programs on your PC.​

                      Also, please ensure that controller support is turned off in the Steam controller settings.​
                      Ahh! It's my fault.
                      Turned off Steam and it worked again.​

                      Comment


                      • #12
                        Glad to know.
                        Should you have any other questions or require further assistance, please let us know.

                        Comment

                        Working...
                        X