No announcement yet.

The Witcher 3 doesn't recognize my Xbox Elite 2 controller anymore

  • Filter
  • Time
  • Show
Clear All
new posts

  • The Witcher 3 doesn't recognize my Xbox Elite 2 controller anymore

    Hello everyone.

    Just the other day I came across a new - very odd - behaviour where The Witcher 3 wouldn't recognize my virtual controller using the Elite 2 anymore. This is very puzzling since it has worked for months now.

    Every other profile I have created still works as normal. I have tried every setting and solution I could find (including the hide physical controller option). The only way I can get it to work is to use the DS4 controller as the virtual one. But as soon as I switch back to Xbox One or 360 it's a no go. reWASD itself doesn't seem to be the problem since the profile is being activated via auto-detect sucessfully and I can even display the overlay checking that every button is working as intended - but the game is acting as if there's no controller connected at all...

    There's two things that I have changed before the problem occurred:
    1. I set back the firmware of my controller, but went back again to the newest version, so it's actually the same as before.
    2. I installed the latest reWASD version 6.7

    Even the Xbox accessory app is still intact with all the important settings necessary to use the Elite 2.

    Any help would be greatly appreciated - maybe I am just overlooking something...

    Cheers, Matt

  • #2
    Hey there!

    If the config is activated and all mappings work correctly in the tester, then this is a game’s side issue.
    Please check if your config works correctly in the tester:

    We can only advise you to make a separate config with a virtual DS4 specifically for this game or manually switch the type of virtual device before launching.