Announcement

Collapse
No announcement yet.

Win11 Clean Install - Virtual Xbox One for reWASD not showing on joy.cpl

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Win11 Clean Install - Virtual Xbox One for reWASD not showing on joy.cpl

    Hi Team,

    I hope you're all doing well.

    Was wondering if anyone has encountered this issue before and point me in the right direction.
    • I have formatted my computer and reinstalled Windows 11 22H2. All updates have been applied and all drivers have been installed to the highest version available.
    • When reinstalling reWASD and re-applying the profile, I noticed the following behavior:
      • When reWASD is off:
        • Xbox One Elite 2 Controller is shown in joy.cpl (native behavior as expected)
      • When reWASD is on:
        • The Virtual Xbox One for reWASD device is:
          • Shown in Control Panel -> Devices and Printers
          • Not shown in joy.cpl
          • Pads mappings in rewasd reflected correctly at gamepad tester website.
    • In both instances, I am able to test the gamepad using the gamepad tester website.
    Unfortunately, the intention here is to use reWASD with FFXIV, which relies on the controller being shown in joy.cpl for it to work.

    Any ideas on how to proceed?

    Note: Before formatting, reWASD was working fine for almost 2 years.

    Thanks in advance!


    Screenshots below:

    reWASD On: Here we can see the mappings activated on reWASD, joy.cpl being blank, "Virtual Input Device for reWASD" on Win11s Devices and Printers Screen, GamePad Tester successful test.
    Click image for larger version

Name:	rewasd_on.png
Views:	305
Size:	1.19 MB
ID:	239498

    reWASD OFF: Here we can see the mappings deactivated on reWASD, joy.cpl & Win11's Devices and Printers Screen showing the Xbox One Controller, GamePad Tester successful test.
    Click image for larger version

Name:	rewasd_off.png
Views:	194
Size:	1.20 MB
ID:	239499


    With reWASD On, unfortunately FFXIV does not see the controller (since it relies on joy.cpl):
    Click image for larger version

Name:	ffxiv.png
Views:	201
Size:	290.5 KB
ID:	239500


    Some screenshots from my configuration below:

    Click image for larger version

Name:	Virtual_Controller_Settings.png
Views:	233
Size:	237.9 KB
ID:	239501
    Several screenshots of settings in reWASD
    Caption









  • #2
    I suppose it would be best to check the msinfo file first.

    Please send us the file with system information. It doesn’t include any personal data but shows active processes, installed apps and drivers.
    1. Type ‘msinfo’ in Windows search
    2. Press Enter to open System Information tool
    3. Go to File -> Save
    4. Send me the *.nfo file you get​

    Comment


    • #3
      Thanks for your quick reply! I'll attach it now via a PM.

      Comment


      • #4
        What happens if you create virtual xbox 360 instead?

        Comment


        • #5
          There is nothing in msinfo file. Please check other virtual controllers.

          Comment


          • #6
            Good Morning DevX / Miron4ik42,

            Thank you both for your efforts/support here.

            I've tried all Virtual Controllers. There's mixed success here:
            • Virtual Xbox 360: No joy.cpl entry / Success in Gamepad Tester [Same as Virtual Xbox One] / Entry in Devices & Printers "Virtual Xbox One for reWASD".
            • Virtual Xbox One: No joy.cpl entry / Success in Gamepad Tester / Entry in Devices & Printers "Virtual Xbox One for reWASD".
            • Virtual DS4: Joy.cpl Entry!!! "Wireless Controller" / Success in Gamepad Tester / Entry in Devices & Printers "Virtual DualShock for reWASD".
            • Virtual DS3: No joy.cpl entry / Success in Gamepad Tester [Same as Virtual Xbox One] / Entry in Devices & Printers "Virtual DualShock for reWASD".
            • Virtual Switch Pro: No joy.cpl entry / Success in Gamepad Tester [Same as Virtual Xbox One] / Entry in Devices & Printers "Virtual Switch Pro for reWASD".
            Question from my side: Is there a command in terminal I can execute to force a driver uninstall/reinstall? (I use at work devcon a lot for this type of issues, so if you point me to where the driver infs are, I can problably try force an inf uninstall/reinstall.)

            Some screenshots below.

            Have a great day!

            -Raul

            Click image for larger version

Name:	PS4.png
Views:	230
Size:	681.8 KB
ID:	239520

            Click image for larger version

Name:	360.png
Views:	172
Size:	749.1 KB
ID:	239521

            Comment


            • #7
              Hi Team,

              Just wanted to give an update on what I've done today. (Spoiler Alert: Problem has been solved.)
              • I used Win11's "Reset this PC".
                • 1x - Keeping the Data: Final Outcome - No change
                • 1x - Deleting the Data: Final Outcome - No Change
              • Then I just bit the bullet and re-formatted.
                • Re-Installed the Drivers & reWASD. Final Outcome - No Change
              At that point I started thinking "it's not me... it's the software". So then I proceeded to uninstall reWASD and:
              • Downloaded reWASD 6.7.0 (Filename: rewasd670-8055.exe): Final Outcome - No change.
                • Uninstalled it and downloaded reWASD 6.6.0.7770 (Filename: reWASD660-7770.exe): Final Outcome: Success!!!
              See screenshot below for evidence.

              In the end, I might think of updating now to 6.7.1 in a couple of days. For now, time to wait for FFXIV to finish downloading, then comes chocolatey downloads and play for a bit.

              Hope this helps anyone else encountering a similar issue.

              Thanks you all for your time trying to help on this endeavor.

              -Raul
              reWASD 6.6.0.7770 - Successfully Fixed
              Caption

              Comment


              • #8
                It looks completely weird. I have never seen such behavior before.

                Please choose Virtual 360 controller and apply the config. Then, go to DM, select View [Device by connection], open your controller, and show us the window you get. Also, enable Show hidden devices as well

                Comment


                • #9
                  Hi Miron,

                  Thanks for the further reply.

                  As I mention on my previous post, I've solved the issue by installing reWASD v6.6.0

                  Currently focusing on just re-downloading everything, since I re-formatted twice in a row trying to get rid of the issue.

                  Have a great afternoon!

                  Comment

                  Working...
                  X