No announcement yet.

Right stick on Xbox mapped to WASD , mouse does not turn camera when i move forward

  • Filter
  • Time
  • Show
Clear All
new posts

  • Right stick on Xbox mapped to WASD , mouse does not turn camera when i move forward

    Hi , so i noticed this increasingly lately , not sure if it because of steam controller support or game controller support. In this case it is resident evil 3. I've had this before and got it to work before , but cant remember what i did. I use mouse with right hand and controller with left hand , so with the left stick mapped to WASD , i don't have to lean over the keyboard holding WASD on there. I just push the stick forward and turn with the mouse as i go. So when i stop pushing the stick forward , i can then turn the camera , and push stick forward again. But then it's move , turn , move , turn , etc......Where i want to be able to push the left stick forwards and just turn with the mouse as i go at the same time. If i do use the keyboard WASD keys with the mouse , then it works normally . Wondering if anyone has run into this , or knows a workaround. thanks

  • #2
    If you want to control your game with mouse and keyboard inputs:
    • Create a new profile/config.
    • Enable the [Mute all] option of the [Magic Wand] menu.
    • Remap your controller to the corresponding mouse and keyboard inputs.
    • Optional: select your physical mouse and keyboard at [Preferences > Input devices].
    If you want to control your game with controller inputs:
    • Make sure the [Advanced Mapping] feature is activated.
    • Create a new profile/config.
    • Group up your mouse and controller.
    • Remap mouse buttons to corresponding controller inputs.


    • #3
      Hmm , ok , thanks , let me try it.


      • #4
        Well , i tried both things , but still character won't turn with mouse when pressing forward on the stick . only if pressing W on the keyboard. It could have something to do with the game's , or Steam's controller support.


        • #5
          Please provide a screenshot of the reWASD window with your controller and config selected.
          Even though it was mentioned as "optional", did you set your keyboard as an endpoint device for remapping at "Preferences > Input devices".


          • #6
            I got it , if i go into Steam and big picture mode and enable Xbox controllers and generic controllers , it just works , not sure why , i did it before but couldn't remember what i did. Thanks for help , i see now there is sections in reWASD that i didn't even know were there.