Announcement

Collapse
No announcement yet.

Destiny 2 - Input Lag when moving/keep key pressed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Destiny 2 - Input Lag when moving/keep key pressed

    Hello,
    I tried a few Destiny 2 profiles and I settled with the one named "Destiny 2 PC" from Legend from here: https://www.rewasd.com/community/gam...oller-support#
    I tried other profiles (3-4 similar) and I experienced the same issue:
    It feel like when I move (or keep any button pressed ), the rest of the buttons are much less reponsive.
    Shooting, Aimin (mouse) seems to work fine, but any other ability (keyboard binds) need multiple presses, and sometime they dont work.
    Similar issue with looking around: while moving/running, the mouse to right/left/up/down (looking around), is much slower than when I am not moving.

    Any tips on how can I debug/fix this behaviour ?

    Thank you!

  • #2
    Hey there!

    The input lag of our virtual devices is identical to the input lag of their physically connected counterparts. Such a delay is less than 5ms and is invisible to the human eye. This means that reWASD does not add any additional input delay. We even don't have the option to change the delay input.

    Please record a video showing your issue and send us a screenshot of the full reWASD window with your mappings.

    Comment


    • #3
      This is the config. I dont know how to capture the fact that I press a key but it does not register !?
      Attached Files

      Comment


      • #4
        Hi,
        I narrowed the issue.
        Is not the keyboard itself. I have a few keys mapped on my mouse (G604) with the Logitec Hub.
        I saved in the memory profile, and they work fine while not pressing enything else.
        If I press Forward (w) none of the mouse2Keyboard mapping buttons work ... unless I spam and wait a few seconds.
        Hope this helps.

        Comment


        • #5
          Originally Posted by Nidark View Post
          This is the config. I dont know how to capture the fact that I press a key but it does not register !?
          As an option, you can use your phone camera to record such a video.
          And I suggest using this tester.

          Hi,
          I narrowed the issue.
          Is not the keyboard itself. I have a few keys mapped on my mouse (G604) with the Logitec Hub.
          I saved in the memory profile, and they work fine while not pressing enything else.
          If I press Forward (w) none of the mouse2Keyboard mapping buttons work ... unless I spam and wait a few seconds.
          Hope this helps.
          1. How are your devices connected to a PC?
          2. Does this exact behavior persist without reWASD?
          3. Have you tried using our other virtual controllers?

          Comment


          • #6
            Well ... it seems the keyboard Reload does not work either when moving. So not that narow

            Comment


            • #7
              Originally Posted by Gogeba View Post
              As an option, you can use your phone camera to record such a video.
              Yep I could try this ^^

              And I suggest using this tester.
              Forgot about the tester - I will give it a try.



              1. How are your devices connected to a PC?
              2. Does this exact behavior persist without reWASD?
              3. Have you tried using our other virtual controllers?
              1. Keyboard Cable / Mouse Bluetooth
              2. No
              3. No. I took a profile already done .. is theer any controler that has issues ?

              Comment


              • #8
                I can't say for sure.. However, it is better to check how all virtual controllers work. Please go to Virtual Controller settings and check if this issue still persists.
                Click image for larger version

Name:	image.png
Views:	315
Size:	455.1 KB
ID:	239916

                Comment


                • #9
                  Thnak you for reminding me the tester usage!
                  This helped me to identify the issue much easier than testing in game.

                  Initiatly when I read the Remapping a mouse with programmable buttons I just screend the ​steps, and as I just took a profile from the comunity, I did not actualy map again the buttons.
                  I had the impressio that if I have C mapped on my keyboard and C mapped in the Mouse software will work .. but it seems I need to map again C in REWASD on the mouse interface.
                  Seems to be working now ... I just need to remap all!
                  Attached Files

                  Comment

                  Working...
                  X