Announcement

Collapse
No announcement yet.

Virtual controller not used in Sekiro via steam

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Virtual controller not used in Sekiro via steam

    I've been using rewasd to add missing control features to PC games for years and love it.

    Despite all this time, I have a new problem that I've never had before.

    I bought Sekiro on steam today and when I change the key mapping on my dualsense, the changes are not taken into account by the game.

    It seems that the game uses the physical controller and the Xbox 360 virtual controller is ignored. Note that key assignment changes on the keyboard are taken into account by the game.

    I could simply map keyboard keys to the controller, but it's still strange.

    Do you know if there's a way to use the virtual controller in this game?‚Äč
    Attached Files

  • #2
    Hey there!

    If you are using Autodetect, then please ensure that you have selected all .exe game processes (you can do this from the active processes).

    Please apply the config manually and check if it works correctly in the tester: https://hardwaretester.com/gamepad
    If everything works correctly in the tester, please try to apply the config manually and check if everything works in the game.

    Also, try disabling controller support in the Steam controller settings.

    Comment


    • #3
      With the configuration applied manually, it works correctly in the tester but still the same in the game, only the physical dualSense is used.

      I deactivated the controller in steam, restarted the game, but with no effect.

      I've seen a lot of articles in the past about people whose controllers weren't detected in this particular game via steam. Controller support in steam seems strange, let's put it this way.
      Attached Files

      Comment


      • #4
        If your config only remaps [X] to [O], you can use the [Native mapping] instead (requires [Advanced Mapping] feature to work).
        Otherwise, you have to enable the [Hide physical controller when virtual one is created] option at [Preferences > Gamepads], as it seems to be disabled.

        Comment


        • #5
          Originally Posted by Support Agent View Post
          If your config only remaps [X] to [O], you can use the [Native mapping] instead (requires [Advanced Mapping] feature to work).
          Otherwise, you have to enable the [Hide physical controller when virtual one is created] option at [Preferences > Gamepads], as it seems to be disabled.
          It's working with this option to [Hide physical controller when virtual one is created].

          Thanks

          Comment

          Working...
          X