No announcement yet.

Gyro goes crazy unless I end Game Controller Mapping Service

  • Filter
  • Time
  • Show
Clear All
new posts

  • Gyro goes crazy unless I end Game Controller Mapping Service

    Greetings to the fantastic team behind this awesome software!
    Sadly I have a problem that almost ruined the joy of obtaining a long-awaited 8bitdo Ultimate Bluetooth Controller : (

    I set it up as a Switch Pro controller, with reWASD running in the background (without touching any settings), and went ahead to mess with emulators.
    But gyro turned out barely controllable. When I run Yuzu the parallelepiped, that shows the gyro movement acts as if it was flowing in the water - slowly rotating in all directions when the controller is lying on the table and spins like crazy when I move the controller.
    In games, it feels like some constant drifting of the camera. The same behavior in other emulators and test utilities.
    SO I checked the pad it on the laptop where I barely have any additional software at all - the pad worked fine.
    SO I was trying to shut down all possible apps on my PC, including reWASD from the tray - no result. Was trying to fix the gyro with the reWASD configuring (turning off mappings, blacklisting the pad, etc) - no result.

    Now it's time to mess with the pad's firmware!
    The default is 1.09. And that's it - no other options available.
    So I dug older versions from the Internet and downgraded them manually.
    1.03 - the problem fixed O_o
    1.04 - didn't try this one
    1.05 - the problem fixed
    1.06 - problem returned
    1.09 - problem remains
    1.10B2SP - problem remains

    Interesting, but I really do not want to use the older firmware cuz many bugs were fixed in the later version : (

    Trying to kill every process I could, I found that:
    - killing the Game Controller Mapping Service
    - turning off the controller and turning it on again
    fixed the problem with the latest firmware!
    But doing it every time is pretty annoying : (

    As soon as I run the reWASD again - the problem returns immediately.

    What's also interesting - I mapped the mouse to the gyro to better visualize the problem. And it was slowly drifting to the side, making me think that it just confirmed the problem. BUT I noticed that the cursor doesn't go like crazy and tried to increase the dead zone in the advanced settings. And now the cursor works perfectly O_o

    SO I can literally see how gyro-mouse works fine, while the Yuzu's parallelepiped spins like crazy.

    I use the latest reWASD 7.1
    I was hoping to try to downgrade the reWASD but it doesn't allow me to install the older version over the newest one. The reinstall process doesn't look simple and requires reboots so I didn't downgrade the app.

    I may still miss anything, maybe some conflict with other drivers, I don't know... I spent the entire weekend trying to figure all of this out and my head spins just like that damn parallelepiped : (
    So let me know if you need some more info.

    reWASD breaks the gyro system-wide, on my new 8bitdo Ultimate Bluetooth Controller (with firmware starting from 1.06) and the only way to fix it is to kill the Game Controller Mapping Service. After the reWASD restart the problem returns.
    How to fix it?

  • #2
    Have you tried the [Calibrate] option of the device icon context menu?


    • #3
      Originally Posted by Support Agent View Post
      Have you tried the [Calibrate] option of the device icon context menu?
      Oh, yes, I did.
      Auto calibration doesn't help and manual calibration says it couldn't find the stable position. The only way to calibrate that I found was the downgrading of the firmware to 1.03/1.05. But upgrading it back to 1.09 brings all problems back : (


      • #4
        Unfortunately, this issue is directly related to the firmware of the device since reWASD does not physically affect your device and outputs the same input as your controller. Therefore, you need to contact 8bitdo technical support directly.
        Thank you for your understanding.


        • #5
          I see. Well, I was going to contact 8bitdo, just needed some more info.
          If I get some progress - I will come back and let know.
          Thanks for clarifying, it should help.