No announcement yet.

Controller detected but inputs are not on Shadow Streaming PC

  • Filter
  • Time
  • Show
Clear All
new posts

  • Controller detected but inputs are not on Shadow Streaming PC

    Hey there!
    I am currently testing out a shadow ( PC in the cloud. The local connected controller will be mapped to a virtual one on the shadow PC to be used for gaming.
    This works fine for everything besides ReWASD. All games, steam, windows configuration tools, etc detect the controller AND the input i make on it, but in ReWASD it detects the connected controller but no keypress is recognized. Anything i can do there? Desperately searching for a way to map the missing MFI iOS controller buttons to a combination of other buttons and ReWASD seems to be the only solution in the whole internet.

  • #2

    Thank you for the problem reporting, This is a known issue, however, we have no chance to test reWASD with Shadow yet. Therefore, we would appreciate your assistance:

    1. What mappings do you use keyboard mapping or with a virtual controller?
    2. Does virtual controller appear in the system (to check it - press win and type joy.cpl) Take the screenshot?
    Don't worry! Be Happy!


    • #3
      Click image for larger version

Name:	7FCB225C-99AD-4328-8AAA-F333961B5B17.jpg
Views:	1
Size:	49.6 KB
ID:	200016


      • #4

        Thank you for the information. In case you can't use the controller with running reWASD, please try to map any buttons using a touchpad on Ipad or the mouse in the PC and apply it? Will then mapped button work?
        Also, check if this option is checked if not, please check it to select required control by pressing these buttons on the gamepad.
        Don't worry! Be Happy!


        • #5
          Yes hook controller is on.
          No nothing happens whatever i tried. Mapped a controller button to a keyboard output and opened notepad: nothing.
          Troed advanced mapping trial to remap a controller button to some other controller button: nothing.


          • #6
            Could you please check whether the Virtual Input for reWASD is installed? This device should reproduce the keyboard mappings that do not work for you now.

            Please follow this steps:
            - Open "Control Panel\All Control Panel Items\Devices and Printers"
            - Check whether you see the composite keyboard-mouse device with reWASD logo (1)
            - If yes, choose Properties from its context menu
            - In the window that will open, go to Hardware tab (2)
            - Pick the keyboard and click Properties button
            - In the next window, switch to Details tab (3) and choose Device stack (4) from the drop-down list

            Here is how it should look like:

            I would kindly ask you to make the similar screenshot from your Shows PC.


            • #7
              Here you go! Seems fine to me.

              Click image for larger version

Name:	DeviceStack.jpg
Views:	1
Size:	65.7 KB
ID:	200017


              • #8
                Sry doublepost: Here are the Details about the Virtual XBOX Controller that shadow creates on the Shadow PC:

                Click image for larger version

Name:	virtualcontroller.PNG
Views:	1
Size:	87.2 KB
ID:	200018

                I tried reWASD with another Virtual Controller Software on my local PC to check if it is a General Problem regarding virtual Controllers, but the "Virtual Controller" Software i installed here works perfectly fine with the local installation of reWASD. So something is incompatible on that ShadowPC.


                • #9
                  This case is truly extremely strange, but thanks a lot for helping us with the investigation.

                  There is one more thing I would kindly ask you to do: collect reWASD logs.

                  Please perform the following steps:
                  - Unplug your controller, so you won't see the virtual Xbox 360 on the virtual machine
                  - Run reWASD as Administrator
                  - Go to Preferences (the icon at the bottom-right) and click "Start Log" button you will see there
                  - Connect your controller, wait a bit while it is connected and appears in the system and reWASD
                  - Click any controller button (one digital button press and one stick move for example)
                  - Go to Preferences once again and press "Stop Log"
                  - Then reWASD will suggest you to go to the folder where the logs are stored. Please send the *.zip file you get to us (you may use email if it is convenient for you).


                  • #10

                    We received the zip archive with the required log. Will study it and let us know updated info.

                    Thank you for your cooperation.
                    Don't worry! Be Happy!


                    • #11

                      After deep investigation, we came to some results. Shadow PC uses the open-source driver to create a virtual controller you get in your Windows 10. This controller is not reported similar to the physical one and so reWASD doesn't support it. However, we have some ideas about how to work with this driver and hope to add the necessary changes to the next version that is scheduled to be released next week. Stay tuned


                      • #12
                        You are officially awesome. Thank you very much for the investigation!


                        • #13
                          Thank you for reporting such a tricky case :satisfied:


                          • #14
                            It wooooorks!
                            How awesome is that, thank you very much again!


                            • #15
                              Ok, it NEARLY works. Remapping single buttons is fine, but the combinations does not work.
                              See screens - if i remap A with controller mapping to B, it only presses B when i press the A button:
                              Click image for larger version

Name:	FA4F86F6-E690-4A21-B3FC-D9B6D3C47E92.jpg
Views:	1
Size:	10.5 KB
ID:	200019

                              When i remap A to B using the rewasd mapping, it presses A and B when i press the A button, strange but ok:
                              Click image for larger version

Name:	E40EDF43-C482-43EC-A173-EEF713EE73F5.jpg
Views:	1
Size:	11.4 KB
ID:	200020

                              But then i configured a combination (thats what i wanted to do for the MFI controller) and it just presses the normal buttons, not the combination result:
                              Click image for larger version

Name:	2334EF10-C7B0-4B60-90E1-584A265C433A.jpg
Views:	1
Size:	9.3 KB
ID:	200021

                              Did i miss something?