Announcement

Collapse
No announcement yet.

Is it possible to have a 'toggle' button to turn off a specific Input?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is it possible to have a 'toggle' button to turn off a specific Input?

    I "THINK" there is a key to turn off profile/ turn on, but im not 100% sure. however that wouldn't work with what Im thinking because it takes a second or two to activate.

    For some random reason, I had a dream about Rewasd last night, where I was playing a game with rewasd controls, Except I was able to instantly enable/disable the Mouse only portion of Rewasd while still being able to use my keyboard controls. What this allowed me to do, was have the mouse REWASD disabled so I would be using my normal sensitivity, until I was about to shoot someone, then I pressed my button and it would enable the mouse profile again, so I would then get the aim assist. This probably sounds pretty dumb, and Im not sure if this would work because I believe switching between KB+Mouse / Controller inputs causes delays in some games doesnt it? Anyways, I just wanted to ask, do you think there is any way to make my dream come true ?

  • #2
    The switch between mouse remapped to a virtual controller stick and normal not remapped mouse you can use [Shifts]. We have an article on how to set up a key for that here.

    You would also need a [Rapid Fire] feature, to be able to "toggle" between two modes, otherwise you'd have to hold the button for "normal mouse" mode.

    Or you could use a [Slots] variant, though switching between them might take a second or two depending on the configs applied.

    Comment


    • #3
      Originally Posted by Shion View Post
      You would also need a [Rapid Fire] feature, to be able to "toggle" between two modes, otherwise you'd have to hold the button for "normal mouse" mode.
      On Shift 0 (Main configuration), I put only the Keyboard layout.
      On Shift 1, I put the Mouse layout for Controller.
      I then Put the key for Shift1 to Left Windows / Q.
      I saved/applied, and Turned on Rewasd.
      However the shift is not working. When i press the Shift 1 key, its not using that map layout. What did i do wrong?
      Last edited by klaz48; 24.11.2021, 09:22.

      Comment


      • #4
        Please send us the config you are using to check what is going wrong. Right-click on the name of the config you're using to open the contextual menu, and choose Open file location. I am asking about *.rewasd file.

        Also, please define which license you use. Do you have Rapid Fire feature enabled or not?

        Comment


        • #5
          Originally Posted by reWASDer View Post
          Please send us the config you are using to check what is going wrong. Right-click on the name of the config you're using to open the contextual menu, and choose Open file location. I am asking about *.rewasd file.

          Also, please define which license you use. Do you have Rapid Fire feature enabled or not?
          No i dont have rapid fire. However I dont want to "toggle" between them. I only want shift 1 activated while "holding" Q (that is my preference)

          I've attached my file, assuming it shows the edited things I've done to it (I downloaded a file from this website, edited it, then saved it)
          Attached Files

          Comment


          • #6
            Thank you for sharing!

            In your config, both keyboard and mouse are remapped to the virtual controller in the Main configuration. I assume this is how you want it to work, right?

            Still, there is no Shift with Q modifier, and your Shift 1 and Shift 2 layer do the same as Main, as all the settings are inherited.

            You need to set Q as a modifier:

            Click image for larger version

Name:	74e94fa13a.png
Views:	26
Size:	53.1 KB
ID:	228608

            ... and then you need to set Do not inherit to all keyboard keys and mouse buttons (the mouse directions are not inherited). Here is an example: https://recordit.co/2JIscs1GOa (Toggle is optional and is not required in your case).

            Comment


            • #7
              Originally Posted by reWASDer View Post
              Thank you for sharing!

              In your config, both keyboard and mouse are remapped to the virtual controller in the Main configuration. I assume this is how you want it to work, right?

              Still, there is no Shift with Q modifier, and your Shift 1 and Shift 2 layer do the same as Main, as all the settings are inherited.

              You need to set Q as a modifier:

              ... and then you need to set Do not inherit to all keyboard keys and mouse buttons (the mouse directions are not inherited). Here is an example: https://recordit.co/2JIscs1GOa (Toggle is optional and is not required in your case).
              Im guessing it didnt save my current settings to the file i uploaded then, because I already have Shift 1 to Keyboard [Q] like you posted in the screenshot. I also shouldnt have anything in shift 2, all it should have is the Keyboard Config on Shift 0, and The Mouse config to Shift 1. Then holding Q i will be able to use Shift 1 (mouse configuration) until i let go of Q. It doesnt matter if the keybinds inherit or not, im fine with whether they do or not

              Comment


              • #8
                If you do not add anything to the Shift layer, then it inherits the mappings from your main configuration by default. If you want to have another behavior in the Shift layer, you need to set it to Do not inherit manually.

                Have you checked this video: https://recordit.co/2JIscs1GOa ? It will help to see what I am talking about.

                Comment


                • #9
                  Originally Posted by reWASDer View Post
                  If you do not add anything to the Shift layer, then it inherits the mappings from your main configuration by default. If you want to have another behavior in the Shift layer, you need to set it to Do not inherit manually.

                  Have you checked this video: https://recordit.co/2JIscs1GOa ? It will help to see what I am talking about.
                  Yes i did, but thats not the problem, the problem is Q isnt activating shift 1.

                  On a side note, could I just put no controls on Shift 0 (So that Rewasd is basically off) and then put both my Mouse+ Keyboard config on my Shift1 Key? Would that make is so rewasd is inactive unless I'm "holding" shift 1 key?

                  Comment


                  • #10
                    Could you please send me your updated config, so I could check Q key right now?

                    You can leave the Main configuration empty, assign Q as Shift 1 modifier and assign all needed mappings inside this Shift only. I assume it is better to use Toggled Shift in this case, so you won't need to press and hold this key always when you want to use your mappings.

                    Comment


                    • #11
                      You can see in my video, I show shift 0 (nothing there besides turn off rewasd), then Shift 1, has both my controls, as well as "E" key for Shift 1. I then Apply settings, and reWASD turns on. I then proceed to hit E, and nothing happens. (If it was working, my mouse would instantly stop moving because it is mimicking a controller, and unbinds mouse movement

                      https://imgur.com/a/osJ11ua

                      Comment


                      • #12
                        1. Please add Unmap to the mouse (inside the Shift):

                        Click image for larger version

Name:	480b014570.png
Views:	5
Size:	111.1 KB
ID:	228629

                        2. It may be a chance that something is wrong with the device initialization. Please show me your group, like here:

                        Click image for larger version

Name:	cb2245abf0.jpg
Views:	5
Size:	35.0 KB
ID:	228630

                        Comment


                        • #13
                          Originally Posted by reWASDer View Post
                          1. Please add Unmap to the mouse (inside the Shift):

                          Click image for larger version

Name:	480b014570.png
Views:	5
Size:	111.1 KB
ID:	228629

                          2. It may be a chance that something is wrong with the device initialization. Please show me your group, like here:

                          Click image for larger version

Name:	cb2245abf0.jpg
Views:	5
Size:	35.0 KB
ID:	228630
                          Yeah, i did notice that myself afterwards, but that wasnt the problem either. Im not sure what the problem was, but for some reason Shift 1 wouldnt work with any keybind, but Shift 2 did. so I just transformed everything from shift 1 to shift 2, and used that instead. So i guess its a temp fix.

                          However, i started noticing something annoying. lets say im holding "W" to go forward in a game, then i Hold my Shift 2 key, without pressing anything else(even if i then let go of W), my character will still go forward until I unhold the shift 2 key and press W again. Kinda made the purpose of what I was trying to do unviable because of it :\

                          Comment


                          • #14
                            So i guess its a temp fix.
                            Not sure why it happens that way but I think it could be considered as solved right now. Hope you will enjoy it this way.

                            im holding "W" to go forward in a game, then i Hold my Shift 2 key, without pressing anything else(even if i then let go of W), my character will still go forward until I unhold the shift 2 key and press W again.
                            At the moment, please ensure that you have added Do not inherit for W in the Shift layer. This way the running will be stopped once you release this key in Shift layer. Still, we are working on the new Shift scheme which will allow you to make this process easier and more accurate. Stay tuned, new Shift mode will be added to the next major release coming at the end of the year.

                            Comment


                            • #15
                              Originally Posted by reWASDer View Post


                              At the moment, please ensure that you have added Do not inherit for W in the Shift layer. This way the running will be stopped once you release this key in Shift layer. Still, we are working on the new Shift scheme which will allow you to make this process easier and more accurate. Stay tuned, new Shift mode will be added to the next major release coming at the end of the year.
                              But if i do do not inherit, and i hold my shift 2 key, then will it still run because W is bound to forward on controlelr even tho Im still holding W down too?

                              Comment

                              Working...
                              X